aboutsummaryrefslogtreecommitdiffstats
path: root/community/icingaweb2-module-incubator/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/icingaweb2-module-incubator/APKBUILD')
-rw-r--r--community/icingaweb2-module-incubator/APKBUILD26
1 files changed, 12 insertions, 14 deletions
diff --git a/community/icingaweb2-module-incubator/APKBUILD b/community/icingaweb2-module-incubator/APKBUILD
index 8e8b4fe04a0..019444e0595 100644
--- a/community/icingaweb2-module-incubator/APKBUILD
+++ b/community/icingaweb2-module-incubator/APKBUILD
@@ -1,15 +1,15 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname="icingaweb2-module-incubator"
+pkgname=icingaweb2-module-incubator
_module=${pkgname/*-/}
-pkgver=0.6.0
-pkgrel=2
+pkgver=0.20.0
+pkgrel=1
pkgdesc="Bleeding edge libraries useful for Icinga Web 2 modules"
-url="https://www.icinga.org"
-arch="noarch !armhf !armv7 !s390x !mips !mips64 !x86"
+url="https://github.com/Icinga/icingaweb2-module-incubator"
+arch="noarch !armhf !armv7 !s390x !x86"
license="MIT"
options="!check"
-_php=php8
+_php=php82
depends="icingaweb2"
pkggroups="icingaweb2"
subpackages="$pkgname-doc"
@@ -20,7 +20,6 @@ build() {
}
package() {
- cd "$builddir"
mkdir -p "$pkgdir/etc/icingaweb2/modules/$_module"
mkdir -p "$pkgdir/usr/share/doc/$pkgname"
mkdir -p "$pkgdir/usr/share/webapps/icingaweb2/modules/$_module"
@@ -32,25 +31,24 @@ package() {
You need to fix /etc/icingaweb2/modules/$_module with the owner of the user of your webserver
For nginx, as example:
- # chown -R nginx /etc/icingaweb2/modules/$_module
+ # chown -R nginx /etc/icingaweb2/modules/$_module
or
- # chown -R nobody /etc/icingaweb2/modules/$_module
+ # chown -R nobody /etc/icingaweb2/modules/$_module
For Apache:
- # chown -R apache /etc/icingaweb2/modules/$_module
+ # chown -R apache /etc/icingaweb2/modules/$_module
For lighttpd:
- # chown -R lighttpd /etc/icingaweb2/modules/$_module
+ # chown -R lighttpd /etc/icingaweb2/modules/$_module
Remember to enable the module with:
- # icingacli module enable $_module
+ # icingacli module enable $_module
EOF
}
-
sha512sums="
-869701c3eca911992e1d32596f8087be896e2f01d9f49551a00dbd8a11e72355b2e1401833249be3e70fb3096ae43aaf2bcf22a53ca7e425fcf5997b43e0110f icingaweb2-module-incubator-0.6.0.tar.gz
+f561d9caffd6d72603debddf61181fa45b43aa4dc44d50749ed5e175c9a3ad169943cb59cfb74e890241cc0af3de0610a1747faa5c14c89ed3ab0b3e3c00da0e icingaweb2-module-incubator-0.20.0.tar.gz
"