aboutsummaryrefslogtreecommitdiffstats
path: root/community/icingaweb2-module-ipl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/icingaweb2-module-ipl/APKBUILD')
-rw-r--r--community/icingaweb2-module-ipl/APKBUILD53
1 files changed, 0 insertions, 53 deletions
diff --git a/community/icingaweb2-module-ipl/APKBUILD b/community/icingaweb2-module-ipl/APKBUILD
deleted file mode 100644
index 3c0169ed6ab..00000000000
--- a/community/icingaweb2-module-ipl/APKBUILD
+++ /dev/null
@@ -1,53 +0,0 @@
-# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname="icingaweb2-module-ipl"
-_module=${pkgname/*-/}
-pkgver=0.5.0
-pkgrel=0
-pkgdesc="The Icinga PHP library for Icinga Web 2"
-url="https://www.icinga.org"
-arch="noarch !armhf !armv7 !s390x !mips !mips64 !x86"
-license="GPL"
-options="!check"
-_php=php7
-pkggroups="icingaweb2"
-subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/Icinga/$pkgname/archive/v$pkgver.tar.gz"
-
-build() {
- return 0
-}
-
-package() {
- cd "$builddir"
- mkdir -p "$pkgdir/etc/icingaweb2/modules/$_module"
- mkdir -p "$pkgdir/usr/share/doc/$pkgname"
- mkdir -p "$pkgdir/usr/share/webapps/icingaweb2/modules/$_module"
- cp -a vendor composer.json composer.lock module.info run.php \
- "$pkgdir/usr/share/webapps/icingaweb2/modules/$_module"
- chgrp -R $pkggroups "$pkgdir/etc/icingaweb2/modules/$_module"
-
- cat >"$pkgdir"/usr/share/doc/$pkgname/README.alpine <<EOF
-You need to fix /etc/icingaweb2/modules/$_module with the owner of the user of your webserver
-
-For nginx, as example:
- # chown -R nginx /etc/icingaweb2/modules/$_module
-or
- # chown -R nobody /etc/icingaweb2/modules/$_module
-
-For Apache:
- # chown -R apache /etc/icingaweb2/modules/$_module
-
-For lighttpd:
- # chown -R lighttpd /etc/icingaweb2/modules/$_module
-
-Remember to enable the module with:
-
- # icingacli module enable $_module
-
-EOF
-
-}
-
-
-sha512sums="8bd85da7b6e94f82ba54ba7d59b619a39b40dc4b5ba376a4444b2bfb594915ef640a1a7b35c343c4348f406110769c28e48e33f410d0162d6d033c7930b74563 icingaweb2-module-ipl-0.5.0.tar.gz"