aboutsummaryrefslogtreecommitdiffstats
path: root/community/icingaweb2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/icingaweb2/APKBUILD')
-rw-r--r--community/icingaweb2/APKBUILD27
1 files changed, 9 insertions, 18 deletions
diff --git a/community/icingaweb2/APKBUILD b/community/icingaweb2/APKBUILD
index 6e0c72dc272..367c44ae6d7 100644
--- a/community/icingaweb2/APKBUILD
+++ b/community/icingaweb2/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=icingaweb2
-pkgver=2.3.4
+pkgver=2.4.0
pkgrel=0
pkgdesc="Web Interface for Icinga2"
url="http://www.icinga.org"
@@ -17,26 +17,17 @@ makedepends="$depends_dev"
pkggroups="icingaweb2"
install="$pkgname.pre-install $pkgname.post-install"
subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp:noarch"
-source="$pkgname-$pkgver.tar.gz::https://github.com/Icinga/${pkgname}/archive/v${pkgver}.tar.gz"
+source="$pkgname-$_pkgver.tar.gz::https://github.com/Icinga/${pkgname}/archive/v${pkgver}.tar.gz"
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
return 0
}
package() {
- cd "$_builddir"
+ cd "$builddir"
mkdir -p "$pkgdir/etc/$pkgname"
mkdir -p "$pkgdir/usr/bin"
mkdir -p "$pkgdir/usr/share/webapps/$pkgname"
@@ -70,11 +61,11 @@ bashcomp() {
depends="bash"
pkgdesc="Bash completions for $pkgname"
- cd "$_builddir"
+ cd "$builddir"
mkdir -p "$subpkgdir"/usr/share/bash-completion/completions
mv etc/bash_completion.d/icingacli "$subpkgdir"/usr/share/bash-completion/completions/icingacli
}
-md5sums="f04d9606f1e52463d11594f3bf492b5c icingaweb2-2.3.4.tar.gz"
-sha256sums="057e9debfbd10df4278dfc675e507b11843478dd7f295c8554cdbc9317dfbd4e icingaweb2-2.3.4.tar.gz"
-sha512sums="b46340563d9c26408f812ab2328520d289447ffc2ad2ca4419b7aa19b663a91fc9bc7841083e1f496bf40f29205f35c0bde2d5980592ac13eccfc8b2bb619b0d icingaweb2-2.3.4.tar.gz"
+md5sums="29b2c8c7db61a0850e8ebe1306ee2518 icingaweb2-.tar.gz"
+sha256sums="aa8c1b2a0e655aa646045cb39c9db054fcb59bd0cac6751934f5b246aa067696 icingaweb2-.tar.gz"
+sha512sums="f2c22e268d7920bccb1be0bb4d177fefebbb4aa87d4e50ba4e80f9f475b2e52b9c6f5fe0624f812eec89d3e5e6a0f77f41d237b8badf52b074571397ff77dc8d icingaweb2-.tar.gz"