aboutsummaryrefslogtreecommitdiffstats
path: root/community/ifstate/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ifstate/APKBUILD')
-rw-r--r--community/ifstate/APKBUILD28
1 files changed, 19 insertions, 9 deletions
diff --git a/community/ifstate/APKBUILD b/community/ifstate/APKBUILD
index 557f1364e1a..170c56f834b 100644
--- a/community/ifstate/APKBUILD
+++ b/community/ifstate/APKBUILD
@@ -1,30 +1,40 @@
# Maintainer: Thomas Liske <thomas@fiasko-nw.net>
pkgname=ifstate
-pkgver=1.4.0
+pkgver=1.11.8
pkgrel=0
pkgdesc="Manage host interface settings in a declarative manner"
-url="https://liske.github.io/ifstate/"
+url="https://ifstate.net/"
arch="noarch"
license="GPL-3.0-or-later"
-depends="iproute2 py3-pyroute2 py3-yaml py3-jsonschema"
-makedepends="py3-setuptools"
+depends="iproute2
+ python3
+ py3-jsonschema
+ py3-pyroute2
+ py3-setproctitle
+ py3-yaml"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
options="!check" # no tests available
source="https://files.pythonhosted.org/packages/source/i/ifstate/ifstate-$pkgver.tar.gz
ifstate.conf
ifstate.initd
"
-subpackages="$pkgname-openrc"
+subpackages="$pkgname-openrc $pkgname-pyc"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
install -Dm755 "$srcdir"/ifstate.conf "$pkgdir"/etc/modprobe.d/ifstate.conf
install -Dm755 "$srcdir"/ifstate.initd "$pkgdir"/etc/init.d/ifstate
}
-sha512sums="7358d625e5c21140a1091f89cec8d3bce9ccabd8551fa0fbc24b00d6c61a87d443fe8a857b680a807b95911c3f4e9e9d4d7c8f276b3e727e5bd7641e03a3747b ifstate-1.4.0.tar.gz
+sha512sums="
+737acd5f41695d463138c7b0c4cf81d90445838ede4cc602647658b0af6fe1ccd896c635640c10a3be5743b202d28f901cb18f4bce898ad02b8be4884d5ac789 ifstate-1.11.8.tar.gz
dfc31dc7452c63ec18d368803ffb3bef1cd96d98345d0c5ef1baeb8b2819130b504d3e6e82d99ee86fa18d4576b7927d0b80d6d79f9f20e388e07faa09a87285 ifstate.conf
-e583c764c65dbf00ce6a4269cef5d8a78c2ec47851671cc25bbebd2d6095c42f0a10eccfd021728e05b3b67d8b950f9e4359da63226da551b8dc5ebd5d8aa0ef ifstate.initd"
+e583c764c65dbf00ce6a4269cef5d8a78c2ec47851671cc25bbebd2d6095c42f0a10eccfd021728e05b3b67d8b950f9e4359da63226da551b8dc5ebd5d8aa0ef ifstate.initd
+"