aboutsummaryrefslogtreecommitdiffstats
path: root/community/ii/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ii/APKBUILD')
-rw-r--r--community/ii/APKBUILD25
1 files changed, 10 insertions, 15 deletions
diff --git a/community/ii/APKBUILD b/community/ii/APKBUILD
index 1a199a12a74..26c62d56874 100644
--- a/community/ii/APKBUILD
+++ b/community/ii/APKBUILD
@@ -1,32 +1,27 @@
# Contributor: lemon <lemon@bitmessage.ch>
-# Maintainer: lemon <lemon@bitmessage.ch>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=ii
-pkgver=1.8
-pkgrel=2
+pkgver=2.0
+pkgrel=1
pkgdesc="Minimalist FIFO and filesystem-based IRC client"
url="https://tools.suckless.org/ii"
arch="all"
license="MIT"
options="!check" # upstream doesn't have a test suite
subpackages="$pkgname-doc"
-source="https://dl.suckless.org/tools/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
-
-prepare() {
- default_prepare
- sed -i "$builddir/config.mk" \
- -e '/CFLAGS/{s/-Os //;s/=/+=/}' \
- -e '/LDFLAGS/{s/-s //;s/=/+=/}'
-}
+source="https://dl.suckless.org/tools/ii-$pkgver.tar.gz
+ use-system-strlcpy.patch
+ "
build() {
- cd "$builddir"
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" PREFIX=/usr install
}
-sha512sums="2b41a0611ac76612c9333e8490709ee22d17506f0c5d7e680a0d8f3f8b511bd5b279555cf609c1543aba71948819369a3c306b1168086890aa49c145b7860e17 ii-1.8.tar.gz"
+sha512sums="
+ab8102b5669495b7bc6a3311245f3eb49d2add1e387290e41deb51e121f4c7c98a09d117052c345d8b896149276a83790c0b78efe3ed19fc52bc00575bf8e44a ii-2.0.tar.gz
+9b58fd48de08b863c4d79bfa54ca38ab7871096236ce716cd9f72625b5621d7b2d8246ab10d8b6cd5ab823da5431efe6e89431b6af8087675715bd7f453f1350 use-system-strlcpy.patch
+"