aboutsummaryrefslogtreecommitdiffstats
path: root/community/img/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/img/APKBUILD')
-rw-r--r--community/img/APKBUILD29
1 files changed, 14 insertions, 15 deletions
diff --git a/community/img/APKBUILD b/community/img/APKBUILD
index 007c0a842ab..8fdc55054a4 100644
--- a/community/img/APKBUILD
+++ b/community/img/APKBUILD
@@ -2,32 +2,31 @@
# Maintainer: Lucas Ramage <ramage.lucas@protonmail.com>
pkgname=img
pkgver=0.5.11
-pkgrel=1
+pkgrel=24
pkgdesc="Standalone, daemon-less, unprivileged Dockerfile and OCI compatible container image builder"
url="https://github.com/genuinetools/img"
-arch="x86_64"
+arch="aarch64 x86_64"
license="MIT"
-options="!check chmod-clean"
-depends="runc shadow-uidmap"
+depends="runc shadow-subids"
makedepends="bash go libseccomp-dev"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/genuinetools/img/archive/v$pkgver.tar.gz"
-builddir="$srcdir/go/src/github.com/genuinetools/img"
+source="https://github.com/genuinetools/img/archive/v$pkgver/img-$pkgver.tar.gz"
+options="!check" # failing tests
-prepare() {
- default_prepare
- mkdir -p "$srcdir/go/src/github.com/genuinetools"
- mv "$srcdir/$pkgname-$pkgver" "$builddir"
-}
+export GOFLAGS="$GOFLAGS -modcacherw -trimpath"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- export GOPATH="$srcdir/go"
make BUILDTAGS="seccomp noembed"
}
package() {
- install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
- install -Dm644 README.md "$pkgdir"/usr/share/doc/$pkgname/README.md
+ install -Dm755 $pkgname -t "$pkgdir"/usr/bin
+ install -Dm644 README.md -t "$pkgdir"/usr/share/doc/$pkgname
}
-sha512sums="de80c2c26dd2fb780fb0447f07b5478e1571067ec934fb2adb32dff1aa3853ff872388b9c9c168c139194ab5d38672fb3b4c76c4f77fd8e61ce48bde8cae8c1b img-0.5.11.tar.gz"
+sha512sums="
+de80c2c26dd2fb780fb0447f07b5478e1571067ec934fb2adb32dff1aa3853ff872388b9c9c168c139194ab5d38672fb3b4c76c4f77fd8e61ce48bde8cae8c1b img-0.5.11.tar.gz
+"