aboutsummaryrefslogtreecommitdiffstats
path: root/community/imv/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/imv/APKBUILD')
-rw-r--r--community/imv/APKBUILD34
1 files changed, 18 insertions, 16 deletions
diff --git a/community/imv/APKBUILD b/community/imv/APKBUILD
index c9eb89c4f4e..5937a233864 100644
--- a/community/imv/APKBUILD
+++ b/community/imv/APKBUILD
@@ -1,23 +1,24 @@
-# Maintainer: Drew DeVault <sir@cmpwn.com>
+# Maintainer: Steven Guikal <void@fluix.one>
pkgname=imv
-pkgver=4.3.1
-pkgrel=2
+pkgver=4.5.0
+pkgrel=0
pkgdesc="Image viewer for X11/Wayland"
url="https://sr.ht/~exec64/imv"
-arch="all"
+arch="all !s390x" # freeimage-dev
license="MIT"
makedepends="
- meson
asciidoc
fontconfig-dev
freeimage-dev
- sdl2_ttf-dev
- wayland-dev
- mesa-dev
- libxkbcommon-dev
glu-dev
- pango-dev
inih-dev
+ libheif-dev
+ libxkbcommon-dev
+ mesa-dev
+ meson
+ pango-dev
+ sdl2_ttf-dev
+ wayland-dev
"
checkdepends="
cmocka
@@ -26,11 +27,12 @@ checkdepends="
subpackages="$pkgname-doc $pkgname-wayland $pkgname-x11"
source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~exec64/imv/archive/v$pkgver.tar.gz
move-wayland-and-x11-to-libexec.patch
+ version.patch
"
builddir="$srcdir/$pkgname-v$pkgver"
case $CARCH in
- s390x|mips64|riscv64)
+ s390x|riscv64)
_rsvg=""
;;
*)
@@ -53,14 +55,13 @@ build() {
-Dlibpng=disabled \
-Dlibjpeg=disabled \
-Dlibnsgif=disabled \
- -Dlibheif=disabled \
$_rsvg \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -78,12 +79,13 @@ wayland() {
x11() {
pkgdesc="Image viewer for X11"
depends="$pkgname=$pkgver-r$pkgrel"
- install_if="$pkgname=$pkgver-r$pkgrel libx11"
+ install_if="$pkgname=$pkgver-r$pkgrel xorg-server"
amove usr/libexec/imv-x11
}
sha512sums="
-f70b95f3f99d7d6a9276370650cef0885938464e3a40ab1768231292ba35d9040f7196a5853ea1268fe6d47cf08d129b3fbae1ca215df96d12ccd85b7efd1ee6 imv-4.3.1.tar.gz
+5a192e1721b4752ba98de23e4a709904f43cce6954d1bc4a8feb5fb4921b46d497915fb7b2885cf87a65983fe2727c856d6c0c8b0cca2906e4b069e4a4f9c417 imv-4.5.0.tar.gz
e14260a79083393a5e81933adafe654892d6fc9e33f18eb906e9bcccc4227a9862851e234a0f14b457e87b8a9a7de71168d8b4fa18677b83105ab24bf3dcc60f move-wayland-and-x11-to-libexec.patch
+910880051a25d3dfe6a9dd6fc1db620f09e5bdcef90fff17509d3fc8252cbde3797c52848857d6dbfc47c4231a8152e55bd87bec846dbbdc9e9429091c27fb5c version.patch
"