aboutsummaryrefslogtreecommitdiffstats
path: root/community/imv/version.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/imv/version.patch')
-rw-r--r--community/imv/version.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/community/imv/version.patch b/community/imv/version.patch
new file mode 100644
index 00000000000..a8ce09e3a0f
--- /dev/null
+++ b/community/imv/version.patch
@@ -0,0 +1,16 @@
+--- a/meson.build
++++ b/meson.build
+@@ -8,13 +8,6 @@
+ )
+
+ version = '@0@'.format(meson.project_version())
+-prog_git = find_program('git', required: false)
+-if prog_git.found()
+- git_description = run_command([prog_git.path(), 'describe', '--dirty', '--always', '--tags'])
+- if git_description.returncode() == 0
+- version = git_description.stdout().strip()
+- endif
+-endif
+ add_project_arguments('-DIMV_VERSION="@0@"'.format(version), language: 'c')
+
+ add_project_arguments('-D_XOPEN_SOURCE=700', language: 'c')