aboutsummaryrefslogtreecommitdiffstats
path: root/community/incidenceeditor/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/incidenceeditor/APKBUILD')
-rw-r--r--community/incidenceeditor/APKBUILD31
1 files changed, 18 insertions, 13 deletions
diff --git a/community/incidenceeditor/APKBUILD b/community/incidenceeditor/APKBUILD
index 568e8cdea89..8a974e405e6 100644
--- a/community/incidenceeditor/APKBUILD
+++ b/community/incidenceeditor/APKBUILD
@@ -1,13 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=incidenceeditor
-pkgver=22.04.2
+pkgver=24.02.2
pkgrel=0
pkgdesc="KDE PIM incidence editor"
# armhf blocked by extra-cmake-modules
-# ppc64le blocked by kmailtransport -> qt5-qtwebengine
-# s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !ppc64le !s390x !riscv64"
+# ppc64le, s390x, riscv64 and armv7 blocked by qt6-qtwebengine -> akonadi
+arch="all !armhf !ppc64le !s390x !riscv64 !armv7"
url="https://kontact.kde.org/"
license="LGPL-2.0-or-later AND GPL-2.0-or-later"
depends_dev="
@@ -24,37 +26,40 @@ depends_dev="
kio-dev
kldap-dev
kmailtransport-dev
+ ktextwidgets-dev
kmime-dev
libkdepim-dev
- qt5-qtbase-dev
- samurai
+ qt6-qtbase-dev
"
makedepends="$depends_dev
+ doxygen
extra-cmake-modules
+ graphviz
+ samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/incidenceeditor-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/incidenceeditor.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/incidenceeditor-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
cmake --build build
}
check() {
- cd build
-
# akonadi-sqlite-incidencedatetimetest and akonadi-mysql-incidencedatetimetest require running DBus
# ktimezonecomboboxtest is broken
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "(akonadi-(sqlite|mysql)-incidencedatetime|ktimezonecombobox)test"
+ xvfb-run ctest --test-dir build --output-on-failure -E "(akonadi-(sqlite|mysql)-incidencedatetime|ktimezonecombobox)test"
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-6f253512049f2d28117bcba467e7265a241380436a4f579ad8757ecf96c78a72bee0678c9d2ed415bf3eb2682eb88adcdacc405daf51bad65dd488af997a31f7 incidenceeditor-22.04.2.tar.xz
+ed95e294a56d3d65c69341488ced5ab7bb1ecc8749b19ee91c0537383dd5c5104137dc0196a19a3c0d88c217b87094c8424f57de08df0af1e2e0f40043930cf5 incidenceeditor-24.02.2.tar.xz
"