aboutsummaryrefslogtreecommitdiffstats
path: root/community/incidenceeditor/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/incidenceeditor/APKBUILD')
-rw-r--r--community/incidenceeditor/APKBUILD37
1 files changed, 22 insertions, 15 deletions
diff --git a/community/incidenceeditor/APKBUILD b/community/incidenceeditor/APKBUILD
index 74031932acc..8a974e405e6 100644
--- a/community/incidenceeditor/APKBUILD
+++ b/community/incidenceeditor/APKBUILD
@@ -1,13 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=incidenceeditor
-pkgver=21.08.1
+pkgver=24.02.2
pkgrel=0
pkgdesc="KDE PIM incidence editor"
# armhf blocked by extra-cmake-modules
-# ppc64le blocked by kmailtransport -> qt5-qtwebengine
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x, riscv64 and armv7 blocked by qt6-qtwebengine -> akonadi
+arch="all !armhf !ppc64le !s390x !riscv64 !armv7"
url="https://kontact.kde.org/"
license="LGPL-2.0-or-later AND GPL-2.0-or-later"
depends_dev="
@@ -24,35 +26,40 @@ depends_dev="
kio-dev
kldap-dev
kmailtransport-dev
+ ktextwidgets-dev
kmime-dev
libkdepim-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
"
makedepends="$depends_dev
+ doxygen
extra-cmake-modules
+ graphviz
+ samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/incidenceeditor-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/incidenceeditor.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/incidenceeditor-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
cmake --build build
}
check() {
- cd build
-
- # akonadi-sqlite-incidencedatetimetest requires running DBus
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "akonadi-sqlite-incidencedatetimetest"
+ # akonadi-sqlite-incidencedatetimetest and akonadi-mysql-incidencedatetimetest require running DBus
+ # ktimezonecomboboxtest is broken
+ xvfb-run ctest --test-dir build --output-on-failure -E "(akonadi-(sqlite|mysql)-incidencedatetime|ktimezonecombobox)test"
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-ae150b9c1a753fb09f7c4e04896fad850c4bc3b8344a65444062bd749eda3e5f17371623dc7a56364c4cb483ec3195173bf2f6edd0a6e9c2a35512a7ff0680ec incidenceeditor-21.08.1.tar.xz
+ed95e294a56d3d65c69341488ced5ab7bb1ecc8749b19ee91c0537383dd5c5104137dc0196a19a3c0d88c217b87094c8424f57de08df0af1e2e0f40043930cf5 incidenceeditor-24.02.2.tar.xz
"