aboutsummaryrefslogtreecommitdiffstats
path: root/community/include-what-you-use/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/include-what-you-use/APKBUILD')
-rw-r--r--community/include-what-you-use/APKBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/community/include-what-you-use/APKBUILD b/community/include-what-you-use/APKBUILD
index 7365ec47395..45d115d094a 100644
--- a/community/include-what-you-use/APKBUILD
+++ b/community/include-what-you-use/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=include-what-you-use
-pkgver=0.18
+pkgver=0.21
# Each release is made for particular LLVM version.
# See https://include-what-you-use.org/downloads/.
-_llvmver=14
+_llvmver=17
pkgrel=0
pkgdesc="A tool for use with clang to analyze #includes in C and C++ source files"
url="https://include-what-you-use.org"
@@ -14,16 +14,18 @@ depends="python3"
# -static packages are needed; include-what-you-use depends on LLVM/clang
# internals and some are exposed only in static libs.
makedepends="
- clang-dev=~$_llvmver
- clang-static
+ clang$_llvmver-dev
+ clang$_llvmver-extra-tools
+ clang$_llvmver-static
cmake
- llvm-dev=~$_llvmver
- llvm-static=~$_llvmver
+ llvm$_llvmver-dev
+ llvm$_llvmver-gtest
+ llvm$_llvmver-static
samurai
"
subpackages="$pkgname-dbg $pkgname-doc"
-source="https://include-what-you-use.org/downloads/include-what-you-use-$pkgver.src.tar.gz"
-builddir="$srcdir/$pkgname"
+source="$pkgname-$pkgver.tar.gz::https://github.com/include-what-you-use/include-what-you-use/archive/refs/tags/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
# Tests are broken on other architectures.
if [ "$CARCH" != x86_64 ]; then
@@ -46,6 +48,7 @@ build() {
-DBUILD_SHARED_LIBS=True \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_VERBOSE_MAKEFILE=ON \
+ -DCMAKE_PREFIX_PATH=/usr/lib/llvm$_llvmver \
$CMAKE_CROSSOPTS .
cmake --build build
}
@@ -64,5 +67,5 @@ package() {
}
sha512sums="
-3d3226cbe7ae1b3c1eb19b5647a103b3a20e33a06a2dc6f70ab5f6a90d8753646450f23d825c606bde75412fac40772cad057880da3e5e10323dd0b4b9a08af9 include-what-you-use-0.18.src.tar.gz
+d6940fcde5f8212b7d6e1b3b8c9075157f831320279f5b7e57346c292c5b2cc52b53491a2c65b69dfcbd83ae2246c7c71555416e1faad9fd9a0aff9c12ddf1ba include-what-you-use-0.21.tar.gz
"