aboutsummaryrefslogtreecommitdiffstats
path: root/community/index/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/index/APKBUILD')
-rw-r--r--community/index/APKBUILD37
1 files changed, 21 insertions, 16 deletions
diff --git a/community/index/APKBUILD b/community/index/APKBUILD
index 7cb03e03ddb..9db1d4fecf0 100644
--- a/community/index/APKBUILD
+++ b/community/index/APKBUILD
@@ -1,34 +1,39 @@
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=maui
pkgname=index
-pkgver=2.0.0
-pkgrel=2
+pkgver=3.0.2
+pkgrel=0
pkgdesc="Index file manager based on MauiKit"
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by mauikit
-arch="all !armhf !s390x !mips64 !riscv64"
-url="https://invent.kde.org/kde/index-fm"
+# s390x, x86, ppc64le, riscv64 blocked by mauikit-imagetools
+arch="all !armhf !s390x !x86 !ppc64le !riscv64"
+url="https://invent.kde.org/maui/index-fm"
license="GPL-2.0-or-later"
-depends="
- mauikit-imagetools
- "
+depends="mauikit-imagetools"
makedepends="
extra-cmake-modules
- ki18n-dev
- kio-dev
- knotifications-dev
- kservice-dev
+ ki18n5-dev
+ kio5-dev
+ knotifications5-dev
+ kservice5-dev
mauikit-dev
mauikit-filebrowsing-dev
qt5-qtbase-dev
qt5-qtdeclarative-dev
+ samurai
"
+subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/maui/index.git"
source="https://download.kde.org/stable/maui/index/$pkgver/index-fm-$pkgver.tar.xz"
options="!check" # No tests available
builddir="$srcdir/$pkgname-fm-$pkgver"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr
cmake --build build
}
@@ -37,5 +42,5 @@ package() {
DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-29c757c360d1c763f7135a8043590c92c6c2d695b38480b258d0932104703d3721aab7e5b2fbc5464842088b9ea2a94d979f7ff65d3e9965620de447c489403b index-fm-2.0.0.tar.xz
+72a027979ca6557f0c6ffcd189df944a53137abfb42c015e01de3622ebdf210cf33dd8259d4a98d4340bdce008a08b15ee7132d4f34573320152808a688d0217 index-fm-3.0.2.tar.xz
"