aboutsummaryrefslogtreecommitdiffstats
path: root/community/index/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/index/APKBUILD')
-rw-r--r--community/index/APKBUILD36
1 files changed, 23 insertions, 13 deletions
diff --git a/community/index/APKBUILD b/community/index/APKBUILD
index 6a675add1a3..9db1d4fecf0 100644
--- a/community/index/APKBUILD
+++ b/community/index/APKBUILD
@@ -1,31 +1,39 @@
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=maui
pkgname=index
-pkgver=1.2.1
+pkgver=3.0.2
pkgrel=0
pkgdesc="Index file manager based on MauiKit"
# armhf blocked by qt5-qtdeclarative
-# s390x blocked by mauikit
-arch="all !armhf !s390x !mips64"
-url="https://invent.kde.org/kde/index-fm"
+# s390x, x86, ppc64le, riscv64 blocked by mauikit-imagetools
+arch="all !armhf !s390x !x86 !ppc64le !riscv64"
+url="https://invent.kde.org/maui/index-fm"
license="GPL-2.0-or-later"
-depends="mauikit"
+depends="mauikit-imagetools"
makedepends="
extra-cmake-modules
- ki18n-dev
- kio-dev
- knotifications-dev
- kservice-dev
+ ki18n5-dev
+ kio5-dev
+ knotifications5-dev
+ kservice5-dev
mauikit-dev
+ mauikit-filebrowsing-dev
qt5-qtbase-dev
qt5-qtdeclarative-dev
+ samurai
"
+subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/maui/index.git"
source="https://download.kde.org/stable/maui/index/$pkgver/index-fm-$pkgver.tar.xz"
options="!check" # No tests available
builddir="$srcdir/$pkgname-fm-$pkgver"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr
cmake --build build
}
@@ -33,4 +41,6 @@ build() {
package() {
DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="d467b52c59ee897a6c970394f7482bc7f065cf82f8765be477accb300c39fe8651b81c50abf89f0de8a9aec1d230c2a337a8388dfbb7d5f6f0a7366790050718 index-fm-1.2.1.tar.xz"
+sha512sums="
+72a027979ca6557f0c6ffcd189df944a53137abfb42c015e01de3622ebdf210cf33dd8259d4a98d4340bdce008a08b15ee7132d4f34573320152808a688d0217 index-fm-3.0.2.tar.xz
+"