aboutsummaryrefslogtreecommitdiffstats
path: root/community/innoextract/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/innoextract/APKBUILD')
-rw-r--r--community/innoextract/APKBUILD28
1 files changed, 13 insertions, 15 deletions
diff --git a/community/innoextract/APKBUILD b/community/innoextract/APKBUILD
index aabab6112b5..6ec3f54b810 100644
--- a/community/innoextract/APKBUILD
+++ b/community/innoextract/APKBUILD
@@ -1,33 +1,31 @@
# Contributor: Michael Koloberdin <koloberdin@gmail.com>
# Maintainer: Michael Koloberdin <koloberdin@gmail.com>
pkgname=innoextract
-pkgver=1.8
-pkgrel=3
+pkgver=1.9
+pkgrel=10
pkgdesc="A tool to extract installers created by Inno Setup"
url="https://constexpr.org/innoextract/"
arch="all"
license="Zlib"
-makedepends="cmake boost-dev xz-dev"
+makedepends="cmake boost-dev samurai xz-dev"
subpackages="$pkgname-doc"
-source="http://constexpr.org/innoextract/files/$pkgname-$pkgver.tar.gz"
-
-builddir="$srcdir/$pkgname-$pkgver"
+source="http://constexpr.org/innoextract/files/innoextract-$pkgver.tar.gz"
+options="!check" # no tests
build() {
- cd "$builddir"
- cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr \
- -DCMAKE_BUILD_TYPE=None \
- -DBoost_NO_BOOST_CMAKE=ON \
- .
- make
+ cmake -B build -G Ninja \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=None
+ cmake --build build
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
install -Dm644 README.md "$pkgdir"/usr/share/doc/$pkgname/README.md
install -m644 CHANGELOG "$pkgdir"/usr/share/doc/$pkgname/CHANGELOG
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-sha512sums="2c68009333f02a8a677c084e9c95c835d84a73e60c9b0c70fee5f23fd9a7a640cf2aa7e0476c55579774ac7079498fa24668f9388493bbc13415ff5a5b06ac9c innoextract-1.8.tar.gz"
+sha512sums="
+2b18f7bb7f50744bcb1bdcd25e57e0760193b179c77b55e0f63c537e55afc98de3b0380da3cae470ce97660ed41a7ffbb48c8c25329c9ce9b3811d9aec74bcde innoextract-1.9.tar.gz
+"