aboutsummaryrefslogtreecommitdiffstats
path: root/community/intel-gmmlib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/intel-gmmlib/APKBUILD')
-rw-r--r--community/intel-gmmlib/APKBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/community/intel-gmmlib/APKBUILD b/community/intel-gmmlib/APKBUILD
index ffea797bef8..495f2cf89ee 100644
--- a/community/intel-gmmlib/APKBUILD
+++ b/community/intel-gmmlib/APKBUILD
@@ -1,12 +1,12 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: psykose <alice@ayaya.dev>
+# Maintainer:
pkgname=intel-gmmlib
-pkgver=22.1.4
+pkgver=22.3.17
pkgrel=0
pkgdesc="Intel Graphics Memory Management Library"
options="!check" # tests can't run in check(), only on install
url="https://github.com/intel/gmmlib/"
-arch="aarch64 x86_64 x86"
+arch="aarch64 x86_64"
license="MIT"
makedepends="cmake samurai"
subpackages="$pkgname-dev"
@@ -17,16 +17,13 @@ build() {
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
- # BUILD_TYPE is a separate type for another thing internally,
- # and only takes release
cmake -B build -G Ninja \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
-DCMAKE_BUILD_TYPE=Release \
- -DBUILD_TYPE=Release \
-DRUN_TEST_SUITE=OFF \
- $CMAKE_CROSSOPTS .
+ $CMAKE_CROSSOPTS
cmake --build build
}
@@ -35,5 +32,5 @@ package() {
}
sha512sums="
-cd31611a53474c2d457f9ce1ce903a184b320d398dc2eba1600f5586108cfa156cde584501ce283d51a8cb13d1917789370d194b6ee3b6a2b5d823d1323b0ef2 intel-gmmlib-22.1.4.tar.gz
+073cb2e9ec025ae32e2f33f51547083cd8425b0c7297e361b037c71b55a8d2322cd36ac7cabbf8c7a325f80f1cc97947c0aa8aa833dc5fbae5abe28e9c04451a intel-gmmlib-22.3.17.tar.gz
"