aboutsummaryrefslogtreecommitdiffstats
path: root/community/iotop/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/iotop/APKBUILD')
-rw-r--r--community/iotop/APKBUILD25
1 files changed, 13 insertions, 12 deletions
diff --git a/community/iotop/APKBUILD b/community/iotop/APKBUILD
index ad57ee4fdce..c60e95185b2 100644
--- a/community/iotop/APKBUILD
+++ b/community/iotop/APKBUILD
@@ -1,31 +1,32 @@
-# Contributor:
+# Contributor:
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=iotop
pkgver=0.6
-pkgrel=5
+pkgrel=11
+# source tarballs are gone now using git repo - commit's first 7 chars
+_commit=59e2537
pkgdesc="I/O monitoring tool"
url="http://guichaz.free.fr/iotop/"
arch="noarch"
license="GPL-2.0-or-later"
+install="$pkgname.pre-upgrade"
depends="python3"
-depends_dev=""
makedepends="python3-dev py3-setuptools"
-install=""
-subpackages="$pkgname-doc"
-source="http://guichaz.free.fr/iotop/files/iotop-$pkgver.tar.bz2
+subpackages="$pkgname-doc $pkgname-pyc"
+source="$pkgname-$pkgver-$_commit.tar.gz::https://repo.or.cz/iotop.git/snapshot/$_commit.tar.gz
fix-python.patch"
-builddir="$srcdir"/iotop-$pkgver
+builddir="$srcdir"/iotop-$_commit
build() {
- cd "$builddir"
python3 setup.py build
}
package() {
- cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="b1047da3bc46604447cc8ab22442a3a5381e1a79a6b176fe9ee8402ee5cebb959205407a6aeaffccccde9d2f67624ff8ee6717b051838f13ab88bf3a16db3ab9 iotop-0.6.tar.bz2
-df5b09b20dc5ca3a8e73f39089f8ef2dbc5060b35178067a41ab1fd075922a860458611d5b0e7beb7aca8c9c5853998aeb7529dbccff9ef39daf17cd997cd698 fix-python.patch"
+sha512sums="
+4f64e87cd54c6e998987376eb00e3d1c5b18bf86356b185ce8ee21cdfef2c3a970e607fbd6c8bac9d92c60fa7c122cab8a8d3c10de66c95b602e541ed68cf0e6 iotop-0.6-59e2537.tar.gz
+df5b09b20dc5ca3a8e73f39089f8ef2dbc5060b35178067a41ab1fd075922a860458611d5b0e7beb7aca8c9c5853998aeb7529dbccff9ef39daf17cd997cd698 fix-python.patch
+"