aboutsummaryrefslogtreecommitdiffstats
path: root/community/ipython/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ipython/APKBUILD')
-rw-r--r--community/ipython/APKBUILD40
1 files changed, 22 insertions, 18 deletions
diff --git a/community/ipython/APKBUILD b/community/ipython/APKBUILD
index 89b723410b2..45f5d8d4687 100644
--- a/community/ipython/APKBUILD
+++ b/community/ipython/APKBUILD
@@ -1,27 +1,35 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=ipython
-pkgver=8.2.0
+pkgver=8.22.2
pkgrel=0
pkgdesc="A rich toolkit to help you make the most of using Python interactively"
-options="!check" # Too many tests fail
url="https://ipython.org/"
arch="noarch"
license="BSD-3-Clause"
depends="
py3-backcall
py3-decorator
+ py3-jedi
+ py3-matplotlib-inline
py3-pexpect
py3-pickleshare
py3-prompt_toolkit<3.1.0
py3-pygments
- py3-setuptools
- py3-simplegeneric
py3-stack_data
py3-traitlets
"
-checkdepends="py3-pathlib2 py3-pytest py3-nose py3-matplotlib"
-subpackages="$pkgname-doc"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="
+ bash
+ py3-matplotlib
+ py3-nose
+ py3-pathlib2
+ py3-pytest<8.0.0
+ py3-testpath
+ "
+options="!check" # requires pytest<8.0.0
+subpackages="$pkgname-doc $pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/ipython/ipython/archive/$pkgver.tar.gz"
# secfixes:
@@ -29,27 +37,23 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/ipython/ipython/archive/$pkg
# - CVE-2022-21699
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- # Requires unpackaged 'testpath'
- rm -f IPython/core/tests/test_paths.py
-
- rm -f IPython/core/tests/test_completer.py
-
- # Requires unpackaged 'nbformat'
- rm -f IPython/core/tests/test_run.py
-
- py.test-3 \
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest \
--deselect=IPython/terminal/tests/test_help.py::test_trust_help \
--deselect=IPython/core/tests/test_display.py::test_set_matplotlib_formats_kwargs
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
sha512sums="
-523dabeef9b8457e170d8cc41aaf475239880a635aedac4fd8498cf7febfdab91ae4256f3033d39570dfa6f4f1ca722c010f3c293152d14e17facb030af8fc77 ipython-8.2.0.tar.gz
+b1313637db7fda77b05e776f1bd87cd3c029eda7b3aea084961a0ae11a6b95f44ae29bbc9879854075eda246339c9afb2447451d7ead2a9c4acba5807fa0b63e ipython-8.22.2.tar.gz
"