aboutsummaryrefslogtreecommitdiffstats
path: root/community/ipython/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ipython/APKBUILD')
-rw-r--r--community/ipython/APKBUILD57
1 files changed, 34 insertions, 23 deletions
diff --git a/community/ipython/APKBUILD b/community/ipython/APKBUILD
index 882ac1bcfe3..563dfeab955 100644
--- a/community/ipython/APKBUILD
+++ b/community/ipython/APKBUILD
@@ -1,48 +1,59 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=ipython
-pkgver=7.20.0
-pkgrel=0
+pkgver=8.22.2
+pkgrel=1
pkgdesc="A rich toolkit to help you make the most of using Python interactively"
-options="!check" # Too many tests fail
url="https://ipython.org/"
arch="noarch"
license="BSD-3-Clause"
depends="
- py3-traitlets
+ py3-backcall
+ py3-decorator
+ py3-jedi
+ py3-matplotlib-inline
py3-pexpect
+ py3-pickleshare
py3-prompt_toolkit<3.1.0
py3-pygments
- py3-pickleshare
- py3-decorator
- py3-backcall
- py3-simplegeneric
- py3-setuptools
+ py3-stack_data
+ py3-traitlets
+ "
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="
+ bash
+ py3-matplotlib
+ py3-nose
+ py3-pathlib2
+ py3-pytest<8.0.0
+ py3-testpath
"
-checkdepends="py3-pathlib2 py3-pytest py3-nose py3-matplotlib"
-subpackages="$pkgname-doc"
+options="!check" # requires pytest<8.0.0
+subpackages="$pkgname-doc $pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/ipython/ipython/archive/$pkgver.tar.gz"
+# secfixes:
+# 7.31.1-r0:
+# - CVE-2022-21699
+
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- # Requires unpackaged 'testpath'
- rm -f IPython/core/tests/test_paths.py
-
- rm -f IPython/core/tests/test_completer.py
-
- # Requires unpackaged 'nbformat'
- rm -f IPython/core/tests/test_run.py
-
- py.test-3 \
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest \
--deselect=IPython/terminal/tests/test_help.py::test_trust_help \
--deselect=IPython/core/tests/test_display.py::test_set_matplotlib_formats_kwargs
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
-sha512sums="db53d422d6b8fb1326ec1e38c192b0d6aeea2d1e64fe9489fe4fc76e5c87af51cbeb7ed3a90c1439b4b1c33542c5f77ac82a7b8930a941f1517719c058df95ea ipython-7.20.0.tar.gz"
+sha512sums="
+b1313637db7fda77b05e776f1bd87cd3c029eda7b3aea084961a0ae11a6b95f44ae29bbc9879854075eda246339c9afb2447451d7ead2a9c4acba5807fa0b63e ipython-8.22.2.tar.gz
+"