aboutsummaryrefslogtreecommitdiffstats
path: root/community/ircii/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ircii/APKBUILD')
-rw-r--r--community/ircii/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/ircii/APKBUILD b/community/ircii/APKBUILD
new file mode 100644
index 00000000000..a54c928837f
--- /dev/null
+++ b/community/ircii/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=ircii
+pkgver=20240111
+pkgrel=0
+pkgdesc="Universal IRC for Unix systems"
+url="http://www.eterna23.net/ircii/"
+arch="all"
+license="BSD-3-Clause"
+makedepends="ncurses-dev openssl-dev>3"
+subpackages="$pkgname-doc"
+source="https://ircii.warped.com/ircii-$pkgver.tar.bz2"
+
+# secfixes:
+# 20210314-r0:
+# - CVE-2021-29376
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --with-default-server=irc.oftc.net
+ make
+}
+
+package() {
+ make -j1 DESTDIR="$pkgdir" install
+}
+
+sha512sums="
+4705b851671f89d1b4903539eb7e701913748138d460572bfeb7e6d565e760b9782aecb55d82c691f6f182864b12e78e13a7b5a1e3abcd535e5bc24c9815e1aa ircii-20240111.tar.bz2
+"