aboutsummaryrefslogtreecommitdiffstats
path: root/community/irtt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/irtt/APKBUILD')
-rw-r--r--community/irtt/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/community/irtt/APKBUILD b/community/irtt/APKBUILD
index 7ed3a828326..35e03a5557a 100644
--- a/community/irtt/APKBUILD
+++ b/community/irtt/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Thomas Liske <thomas@fiasko-nw.net>
pkgname=irtt
pkgver=0.9.1
-pkgrel=2
+pkgrel=22
pkgdesc="Isochronous Round-Trip Tester"
url="https://github.com/heistp/irtt"
arch="all"
@@ -16,8 +16,12 @@ source="https://github.com/heistp/irtt/archive/v$pkgver/irtt-$pkgver.tar.gz
install="irtt.pre-install"
subpackages="$pkgname-openrc"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
- go build -ldflags "-s -w" "$(pwd)/cmd/irtt"
+ go build ./cmd/irtt
}
check() {