aboutsummaryrefslogtreecommitdiffstats
path: root/community/irtt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/irtt/APKBUILD')
-rw-r--r--community/irtt/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/irtt/APKBUILD b/community/irtt/APKBUILD
new file mode 100644
index 00000000000..18a36c6be98
--- /dev/null
+++ b/community/irtt/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Thomas Liske <thomas@fiasko-nw.net>
+pkgname=irtt
+pkgver=0.9.1
+pkgrel=23
+pkgdesc="Isochronous Round-Trip Tester"
+url="https://github.com/heistp/irtt"
+arch="all"
+license="GPL-2.0-or-later"
+pkgusers="$pkgname"
+pkggroups="$pkgname"
+makedepends="go"
+options="net"
+source="https://github.com/heistp/irtt/archive/v$pkgver/irtt-$pkgver.tar.gz
+ irtt.initd
+ "
+install="irtt.pre-install"
+subpackages="$pkgname-openrc"
+
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
+build() {
+ go build ./cmd/irtt
+}
+
+check() {
+ go test -v
+}
+
+package() {
+ install -Dm755 irtt "$pkgdir"/usr/bin/irtt
+ install -Dm755 "$srcdir"/irtt.initd "$pkgdir"/etc/init.d/irtt
+}
+
+sha512sums="
+072ce70a996cdc70247e896cc613abba7c21f238a508708934ec6cd04b0dec89408c01b7f82dcee6752aae85bca84f0679d32acd75b607e37614f331c238fad9 irtt-0.9.1.tar.gz
+ebd1912a14d5a189cb7db349a63c7b25fb47c589d351d225e320b0b6892907c42c933e02309457c5168f63f3ce5c8de43da475210b7d8fa4b4fdac0c6d4de684 irtt.initd
+"