aboutsummaryrefslogtreecommitdiffstats
path: root/community/isoimagewriter/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/isoimagewriter/APKBUILD')
-rw-r--r--community/isoimagewriter/APKBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/community/isoimagewriter/APKBUILD b/community/isoimagewriter/APKBUILD
index b0f5c8c67ee..e96dc27770c 100644
--- a/community/isoimagewriter/APKBUILD
+++ b/community/isoimagewriter/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=isoimagewriter
-pkgver=0.8
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kauth
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://community.kde.org/ISOImageWriter"
pkgdesc="A program to write hybrid ISO files onto a USB disk"
license="GPL-3.0-only"
@@ -19,26 +21,30 @@ makedepends="
ki18n-dev
kiconthemes-dev
kwidgetsaddons-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
+ solid-dev
"
-source="https://download.kde.org/unstable/isoimagewriter/$pkgver/isoimagewriter-$pkgver.tar.xz"
subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/utilities/isoimagewriter.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/isoimagewriter-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="1d5031695647be54e5de10f6243b68bf8d2dc29a7894c8ac69954df353d5baa740290b572c89cd37650718749117f5e3b25dd99b8b374d8ba0376288878f9199 isoimagewriter-0.8.tar.xz"
+sha512sums="
+7648e2c494dc8e1a5ef71ab767f474df083fa161427d25f3759811e87477ff103512eafa496f105daac41c249317479c16ccae3e49062cce962a4c1101baf834 isoimagewriter-24.02.2.tar.xz
+"