aboutsummaryrefslogtreecommitdiffstats
path: root/community/ispc/0001-cmake-fixes.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/ispc/0001-cmake-fixes.patch')
-rw-r--r--community/ispc/0001-cmake-fixes.patch21
1 files changed, 6 insertions, 15 deletions
diff --git a/community/ispc/0001-cmake-fixes.patch b/community/ispc/0001-cmake-fixes.patch
index 88c42ea174f..a5838aca0bd 100644
--- a/community/ispc/0001-cmake-fixes.patch
+++ b/community/ispc/0001-cmake-fixes.patch
@@ -1,14 +1,14 @@
-From 6e75a3a671ae9f96372949af07df30db2d69a1dd Mon Sep 17 00:00:00 2001
+From 939338c137f69a818c42b9654acb5a4edbd3981b Mon Sep 17 00:00:00 2001
From: Leon Marz <main@lmarz.org>
-Date: Thu, 1 Jul 2021 15:34:07 +0200
+Date: Fri, 6 May 2022 10:00:06 +0200
Subject: [PATCH] cmake fixes
---
- CMakeLists.txt | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
+ CMakeLists.txt | 2 ++
+ 1 file changed, 2 insertions(+)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index ef88317..1443620 100644
+index 82a58a1..af27a3b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -196,6 +196,7 @@ set(OUTPUT_DEBUG Debug/bin)
@@ -27,15 +27,6 @@ index ef88317..1443620 100644
list(APPEND CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/ispcrt/cmake)
include(${CMAKE_CURRENT_SOURCE_DIR}/cmake/FixWindowsPath.cmake)
-@@ -525,7 +527,7 @@ else()
- else()
- find_package(Curses REQUIRED)
- find_package(ZLIB REQUIRED)
-- find_library(NCURSES_TINFO_LIBRARY tinfo)
-+ find_library(NCURSES_TINFO_LIBRARY ncursesw)
- target_link_libraries(${PROJECT_NAME} pthread ${ZLIB_LIBRARIES} ${NCURSES_TINFO_LIBRARY} ${CURSES_LIBRARIES})
- endif()
- endif()
--
-2.34.1
+2.36.0