aboutsummaryrefslogtreecommitdiffstats
path: root/community/iwgtk/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/iwgtk/APKBUILD')
-rw-r--r--community/iwgtk/APKBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/community/iwgtk/APKBUILD b/community/iwgtk/APKBUILD
index 7ee61fe96a5..556efd7cf4e 100644
--- a/community/iwgtk/APKBUILD
+++ b/community/iwgtk/APKBUILD
@@ -1,26 +1,29 @@
# Contributor: Milan P. Stanić <mps@arvanta.net>
# Maintainer: Milan P. Stanić <mps@arvanta.net>
pkgname=iwgtk
-pkgver=0.6
+pkgver=0.9
pkgrel=0
pkgdesc="graphical wifi management utility for iwd"
url="https://github.com/J-Lentz/iwgtk"
arch="all !s390x !riscv64" # blocked by gtk4.0
license="GPL-3-or-later"
options="!check" # no tests
-makedepends="gtk4.0-dev"
+makedepends="gtk4.0-dev libqrencode-dev meson scdoc"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/J-Lentz/iwgtk/archive/v$pkgver.tar.gz"
build() {
- make PREFIX=/usr
+ abuild-meson --prefix=/usr build
+ cd build
+ meson compile
}
package() {
- make DESTDIR="$pkgdir" PREFIX=/usr install
- rm -rf "$pkgdir"/usr/lib/systemd
+ cd build
+ meson install --destdir $pkgdir
+ rm -rf "$pkgdir"/usr/share/lib
}
sha512sums="
-79874e65d7673100f9156e183387ed0e744de153f8ab3aa3295347ed263b53cd6109e1b7e2d32e7b735a4d09d60235a1124fa244beb989fa4e86044cf7547fb1 iwgtk-0.6.tar.gz
+d755d72744051a39dda0b78dc0fb2cc57cbf44cd095ac595d4e83f22a70471a0d69a406636d0a4d5922b533d1c849578779fd7f4c41a0b0e1549dd4e9cc45c4d iwgtk-0.9.tar.gz
"