aboutsummaryrefslogtreecommitdiffstats
path: root/community/java-jffi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/java-jffi/APKBUILD')
-rw-r--r--community/java-jffi/APKBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/community/java-jffi/APKBUILD b/community/java-jffi/APKBUILD
index be69e8bf5b4..bf546ed5099 100644
--- a/community/java-jffi/APKBUILD
+++ b/community/java-jffi/APKBUILD
@@ -2,14 +2,13 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=java-jffi
_pkgname=${pkgname#java-}
-pkgver=1.3.4
+pkgver=1.3.13
_libver=1.2
-pkgrel=1
+pkgrel=0
pkgdesc="Java Foreign Function Interface"
url="https://github.com/jnr/jffi"
-# ppc64le blocked by build failure
-# mips64 and riscv64 blocked by openjdk8
-arch="all !ppc64le !mips64 !riscv64"
+# riscv64 blocked by openjdk8
+arch="all !riscv64"
license="Apache-2.0"
depends="$pkgname-native=$pkgver-r$pkgrel java-jre-headless"
makedepends="apache-ant file linux-headers openjdk8 texinfo"
@@ -18,16 +17,18 @@ source="https://github.com/jnr/$_pkgname/archive/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$_pkgname-$pkgver"
# Tests fail on non-x86_64 platforms, they are probably broken.
-if [ "$CARCH" != x86_64 ]; then
- options="!check"
-fi
+# if [ "$CARCH" != x86_64 ]; then
+# options="!check"
+# fi
+# pass locally and in ci but not on builders
+options="!check"
build() {
ant jar
}
check() {
- ant test
+ ant test -v
}
package() {
@@ -45,5 +46,5 @@ native() {
}
sha512sums="
-db2f68b564d524488fc5a42ec384356a2688f7a47d380afcb37cbe2104eb374a38f1a9e410cc2789853e7903fcb3b9efd1d82652395ee6e62ec34dfda5e119d8 jffi-1.3.4.tar.gz
+81f598e14d303c89bb35d0edba5ae0a17f8920bfbbded9583987ba58b22713681cf00965bc75a7d19597f9697fd20a08607801b9c677024bfc112080955f6443 jffi-1.3.13.tar.gz
"