aboutsummaryrefslogtreecommitdiffstats
path: root/community/jimtcl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/jimtcl/APKBUILD')
-rw-r--r--community/jimtcl/APKBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/community/jimtcl/APKBUILD b/community/jimtcl/APKBUILD
index 6f2e3fefd95..cb9d5e07619 100644
--- a/community/jimtcl/APKBUILD
+++ b/community/jimtcl/APKBUILD
@@ -1,16 +1,16 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=jimtcl
-pkgver=0.80
-pkgrel=5
+pkgver=0.82
+pkgrel=1
pkgdesc="An open-source, small footprint implementation of Tcl"
url="https://github.com/msteveb/jimtcl"
arch="all"
license="BSD-2-Clause"
-depends_dev="openssl1.1-compat-dev"
+depends_dev="openssl-dev>3"
makedepends="
$depends_dev
- libexecinfo-dev
+ asciidoc
readline-dev
sqlite-dev
tcl
@@ -20,7 +20,6 @@ options="net" # fix check with abuild rootbld
subpackages="$pkgname-dbg $pkgname-readline $pkgname-sqlite3 $pkgname-dev $pkgname-doc"
source="https://github.com/msteveb/jimtcl/archive/$pkgver/jimtcl-$pkgver.tar.gz
tests-skip-exec2-3.2.patch
- fix-memory-leak.patch
tests-skip-socket.patch
"
@@ -34,6 +33,8 @@ prepare() {
}
build() {
+ # CRTSCTS
+ export CFLAGS="$CFLAGS -D_BSD_SOURCE"
_build --shared
cd "$builddir-static"
@@ -49,7 +50,9 @@ _build() {
--full \
--with-mod=sqlite3,readline,rlprompt \
"$@"
- make -j1
+ # https://github.com/msteveb/jimtcl/issues/256
+ CFLAGS="$CFLAGS -D_GNU_SOURCE=1" \
+ make -j1
}
check() {
@@ -58,7 +61,6 @@ check() {
package() {
make install DESTDIR="$pkgdir"
- ln -s /usr/lib/libjim.so.$pkgver "$pkgdir"/usr/lib/libjim.so
install -m644 "$builddir-static"/libjim.a -t "$pkgdir"/usr/lib/
}
@@ -84,8 +86,7 @@ dev() {
}
sha512sums="
-37f14263f2101caaa632acf5e426dd7f1d6f75143875359c1daed59a039a9c64bbdf7941ce12b76bf9b209521b3967fd2b1d94a6afde7b2a8dd173d160858225 jimtcl-0.80.tar.gz
-e9ac362e72d4e51bf21d7d9430c330f1d77cdeeceb574607d5847404fe20d304bb0c7ab405e76b7a84d5dfa115e717a65533aab0626fd80c2535bf8beabb48cf tests-skip-exec2-3.2.patch
-92010f9a0494c2c7a159530182482ac4c24f7cfd5ae8a3dae44432431767342e97f1583fa244608cebf07928276398a398c797f0910b818aa39840410533511c fix-memory-leak.patch
+d0f8c8d515b9c7eee3ee2089a8fe9b8616b0541b7fca6b769132201c3a65a8216f9e8a333c6a3a4c2a8fa4754ab0c9d3c2bca3306b3b4db566d4f3e401a709fe jimtcl-0.82.tar.gz
+188df3307b0983bda5904f1ec26ba195f7cb435244bc516d4b8b5377320ab37a76f44500af6faac1e3dfee2dae8bc8f942b8543268d56aa21bd59de4d34099da tests-skip-exec2-3.2.patch
cbc3f08d23cfe7ebd45e677a09e7178436e728a965ab7af44d6e27621049c1cdc82768c4e81397004be3486bf3f767684601ec28d3584ea14d3dde69ccdd8bdb tests-skip-socket.patch
"