aboutsummaryrefslogtreecommitdiffstats
path: root/community/jql/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/jql/APKBUILD')
-rw-r--r--community/jql/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/jql/APKBUILD b/community/jql/APKBUILD
new file mode 100644
index 00000000000..ee462820e09
--- /dev/null
+++ b/community/jql/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=jql
+pkgver=7.1.7
+pkgrel=0
+pkgdesc="A JSON Query Language CLI tool"
+url="https://github.com/yamafaktory/jql"
+arch="all"
+license="MIT"
+makedepends="cargo cargo-auditable"
+source="https://github.com/yamafaktory/jql/archive/jql-v$pkgver.tar.gz"
+options="net" # fetch dependencies
+builddir="$srcdir/jql-jql-v$pkgver"
+
+prepare() {
+ default_prepare
+
+ cargo fetch --target="$CTARGET" --locked
+}
+
+build() {
+ cargo auditable build --frozen --release
+}
+
+check() {
+ # core::tests::get_property_as_index seems to be broken
+ cargo test --frozen -- \
+ --skip core::tests::get_property_as_index
+}
+
+package() {
+ install -D -m755 target/release/jql -t "$pkgdir"/usr/bin/
+}
+
+sha512sums="
+208a1c11e71198a9ce7cc88038402d69c7cf30e90fba9c39ee5a998b6aa6740cf7e8e4f776f01b102dd6c861c34c546416f048b82bb46ff06fe794faaa7394be jql-v7.1.7.tar.gz
+"