aboutsummaryrefslogtreecommitdiffstats
path: root/community/jruby/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/jruby/APKBUILD')
-rw-r--r--community/jruby/APKBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/community/jruby/APKBUILD b/community/jruby/APKBUILD
index 48c9232bb25..e26a35f3abd 100644
--- a/community/jruby/APKBUILD
+++ b/community/jruby/APKBUILD
@@ -1,16 +1,17 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=jruby
-pkgver=9.2.19.0
+pkgver=9.3.13.0
pkgrel=0
pkgdesc="An implementation of Ruby on the JVM"
url="https://www.jruby.org/"
-# all arches blocked by java-jffi
-arch="noarch !armhf !armv7 !mips !mips64 !ppc64le !x86 !s390x !riscv64"
+# s390x: JVM crash
+# others blocked by openjdk11
+arch="noarch !x86 !armhf !armv7 !riscv64 !s390x"
license="EPL-2.0 OR GPL-2.0-or-later OR LGPL-2.1-or-later AND Ruby"
# libc6-compat: https://github.com/jnr/jnr-posix/issues/73
depends="$pkgname-libs=$pkgver-r$pkgrel
- libc6-compat>=1.1.12-r5
+ gcompat
java-jffi-native>=1.2
java-jre-headless
"
@@ -37,14 +38,16 @@ _stdlibdir="$_rubydir/stdlib"
prepare() {
cd "$builddir"/bin
rm *.bat *.dll *.exe
- rm jirb_swing jruby jruby.* testrb
+ rm jirb_swing jruby jruby.*
cd "$builddir"/lib/ruby/stdlib
- rm -r win32 Win32API.rb
+ rm -r jruby/win32ole win32 win32ole.rb win32api.rb
# Remove useless native binaries from JARs.
zip -qd jline/jline/*/jline-*.jar META-INF/native/*
zip -qd "$builddir"/lib/jruby.jar jni/*
+
+ default_prepare
}
check() (
@@ -102,7 +105,7 @@ rdoc() {
readline() {
pkgdesc="Readline support for JRuby"
- depends="$pkgname java-jansi-native"
+ depends="$pkgname"
_mvgem jruby-readline
_mv $_stdlibdir/jline
@@ -123,7 +126,6 @@ libs() {
_mv $_rubydir/gems $_rubydir/stdlib
}
-
_mv() {
local path; for path in "$@"; do
mkdir -p "$subpkgdir"/${path%/*}
@@ -146,6 +148,6 @@ _mvgem() {
}
sha512sums="
-3740674035e27cf7961b3570ad65536c30faab1c9a71a42a696b173379e79647411d57e0d1d06b5f9c9a970eb02a595a559191af08a083773dc4601dcfd07491 jruby-bin-9.2.19.0.tar.gz
+eb24641fb7a6b9d2039ec953388053e7333b306056f9a5bf745331b04cfc05dc4211a9b7780ce88bcee9184b8cbb219b574574d308bc2720547c116f4d4721dc jruby-bin-9.3.13.0.tar.gz
836a73b46b9ea107b3ab51da9fea73cecd8664b7d72c4024c491c67312e6c094c215aa9d22d1e3f9f2402816bc0200dd4060d1895f4ba28424228d6cdbac8a9d jruby
"