aboutsummaryrefslogtreecommitdiffstats
path: root/community/json-glib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/json-glib/APKBUILD')
-rw-r--r--community/json-glib/APKBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/community/json-glib/APKBUILD b/community/json-glib/APKBUILD
index ae8ff3e7f23..a8ec4fa1789 100644
--- a/community/json-glib/APKBUILD
+++ b/community/json-glib/APKBUILD
@@ -1,26 +1,26 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=json-glib
-pkgver=1.6.2
-pkgrel=0
+pkgver=1.8.0
+pkgrel=1
pkgdesc="JSON library built on GLib"
arch="all"
url="https://wiki.gnome.org/Projects/JsonGlib"
license="LGPL-2.1-or-later"
-makedepends="gobject-introspection-dev glib-dev meson gtk-doc"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-tests $pkgname-dbg"
+makedepends="gobject-introspection-dev glib-dev meson"
+subpackages="$pkgname-dev $pkgname-lang $pkgname-tests $pkgname-dbg"
source="https://download.gnome.org/sources/json-glib/${pkgver%.*}/json-glib-$pkgver.tar.xz"
build() {
abuild-meson \
- -Ddocs=true \
+ -Dgtk_doc=disabled \
. build
- meson compile ${JOBS:+-j ${JOBS}} -C build
+ meson compile -C build
}
check() {
- meson test --no-rebuild -v -C build
+ meson test --no-rebuild --print-errorlogs -C build
}
package() {
@@ -41,4 +41,6 @@ tests() {
"$subpkgdir"/usr/
}
-sha512sums="8412390a639d368ed11181621739f43bc4900143ac062c3824c7140abec58ca2b09773a415034f03896a4ff63aa3414b492997da532848709238a83c3a068b11 json-glib-1.6.2.tar.xz"
+sha512sums="
+e4fe16bb7c5b72fcf9c0966ac1903ff0cd74ec8eab891db4b94e92353bdcb57b24613b6c2cce7bfa1996603c367d1b4939c12209369dfb915aac0f3804a3a900 json-glib-1.8.0.tar.xz
+"