aboutsummaryrefslogtreecommitdiffstats
path: root/community/jsoncpp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/jsoncpp/APKBUILD')
-rw-r--r--community/jsoncpp/APKBUILD18
1 files changed, 5 insertions, 13 deletions
diff --git a/community/jsoncpp/APKBUILD b/community/jsoncpp/APKBUILD
index af16b79e062..96e442c0e71 100644
--- a/community/jsoncpp/APKBUILD
+++ b/community/jsoncpp/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=jsoncpp
pkgver=1.9.5
-pkgrel=0
+pkgrel=2
pkgdesc="JSON C++ library"
url="https://github.com/open-source-parsers/jsoncpp"
arch="all"
@@ -11,26 +11,18 @@ subpackages="$pkgname-static $pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/open-source-parsers/jsoncpp/archive/$pkgver.tar.gz"
build() {
- # we cannot use cmake since jsoncpp is a dependency for cmake which
- # means we would get circular buildtime deps
abuild-meson \
--default-library=both \
- build
- meson compile ${JOBS:+-j ${JOBS}} -C build
+ . output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C build
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
- DESTDIR="$pkgdir" meson install --no-rebuild -C build
-}
-
-static() {
- pkgdesc="JsonCpp static library"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/*.a "$subpkgdir"/usr/lib/
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
sha512sums="