aboutsummaryrefslogtreecommitdiffstats
path: root/community/jsoncpp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/jsoncpp/APKBUILD')
-rw-r--r--community/jsoncpp/APKBUILD24
1 files changed, 9 insertions, 15 deletions
diff --git a/community/jsoncpp/APKBUILD b/community/jsoncpp/APKBUILD
index d56dfb021c2..96e442c0e71 100644
--- a/community/jsoncpp/APKBUILD
+++ b/community/jsoncpp/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=jsoncpp
-pkgver=1.9.4
-pkgrel=0
+pkgver=1.9.5
+pkgrel=2
pkgdesc="JSON C++ library"
url="https://github.com/open-source-parsers/jsoncpp"
arch="all"
@@ -11,26 +11,20 @@ subpackages="$pkgname-static $pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/open-source-parsers/jsoncpp/archive/$pkgver.tar.gz"
build() {
- # we cannot use cmake since jsoncpp is a dependency for cmake which
- # means we would get circular buildtime deps
abuild-meson \
--default-library=both \
- build
- meson compile ${JOBS:+-j ${JOBS}} -C build
+ . output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C build
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
- DESTDIR="$pkgdir" meson install --no-rebuild -C build
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-static() {
- pkgdesc="JsonCpp static library"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/*.a "$subpkgdir"/usr/lib/
-}
-
-sha512sums="adfd4afbdf6b79bd37edcf0e248f07864994f1c4bcb7431f3b44102490ce467f72381908066655fa486dec12f467af0a11f42f859bbf719895974c7339db7d22 jsoncpp-1.9.4.tar.gz"
+sha512sums="
+1d06e044759b1e1a4cc4960189dd7e001a0a4389d7239a6d59295af995a553518e4e0337b4b4b817e70da5d9731a4c98655af90791b6287870b5ff8d73ad8873 jsoncpp-1.9.5.tar.gz
+"