aboutsummaryrefslogtreecommitdiffstats
path: root/community/jsonrpc-glib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/jsonrpc-glib/APKBUILD')
-rw-r--r--community/jsonrpc-glib/APKBUILD31
1 files changed, 15 insertions, 16 deletions
diff --git a/community/jsonrpc-glib/APKBUILD b/community/jsonrpc-glib/APKBUILD
index 30726dae4e9..f91d7e2d10d 100644
--- a/community/jsonrpc-glib/APKBUILD
+++ b/community/jsonrpc-glib/APKBUILD
@@ -1,33 +1,32 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Krassy Boykinov <kboykinov@teamcentrixx.com>
pkgname=jsonrpc-glib
-pkgver=3.34.0
-pkgrel=0
+pkgver=3.44.0
+pkgrel=2
pkgdesc="Library to communicate using the JSON-RPC 2.0 specification"
url="https://gitlab.gnome.org/GNOME/jsonrpc-glib"
arch="all"
license="GPL-3.0-or-later"
-makedepends="gtk+3.0-dev vala gobject-introspection-dev gtk-doc meson json-glib-dev"
-subpackages="$pkgname-dev $pkgname-doc"
-source="https://download.gnome.org/sources/jsonrpc-glib/${pkgver%.*}/jsonrpc-glib-$pkgver.tar.xz
- disable-flaky-test.patch"
+makedepends="gtk+3.0-dev vala gobject-introspection-dev meson json-glib-dev"
+subpackages="$pkgname-dev"
+source="https://download.gnome.org/sources/jsonrpc-glib/${pkgver%.*}/jsonrpc-glib-$pkgver.tar.xz"
build() {
- meson \
- --prefix=/usr \
- --buildtype=release \
- -Denable_gtk_doc=true \
+ abuild-meson \
+ -Db_lto=true \
+ -Denable_gtk_doc=false \
. output
- ninja -C output
+ meson compile -C output
}
check() {
- ninja -C output test
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
- DESTDIR="$pkgdir" ninja -C output install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="58908dd11f7848b09e63f7a7ff2185d0742c049ddffb033e768f783bcbcda7e75a658bec923372212694431b25b0fb894e3ea37ce2d7c52c99e49fd230319c10 jsonrpc-glib-3.34.0.tar.xz
-ec2eea185a86c6ac16fc51c7d67faca7805c69e6127f1288d551ba7249f898672a5a4ef1f2d05531f65e5d5087d4d576b251f3330806809bdeab6abd6593dc34 disable-flaky-test.patch"
+sha512sums="
+85962af18cb62af7c4dfa37289cf53ba9c905ee00994cc6bcc2679f1e0f79ea0b134386179dd2417e6166777d65f025959d6d258aa279bbfb1f4cacceeede7af jsonrpc-glib-3.44.0.tar.xz
+"