aboutsummaryrefslogtreecommitdiffstats
path: root/community/jsonrpc-glib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/jsonrpc-glib/APKBUILD')
-rw-r--r--community/jsonrpc-glib/APKBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/community/jsonrpc-glib/APKBUILD b/community/jsonrpc-glib/APKBUILD
index d4d740ac33e..f91d7e2d10d 100644
--- a/community/jsonrpc-glib/APKBUILD
+++ b/community/jsonrpc-glib/APKBUILD
@@ -1,31 +1,32 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Krassy Boykinov <kboykinov@teamcentrixx.com>
pkgname=jsonrpc-glib
-pkgver=3.38.0
-pkgrel=1
+pkgver=3.44.0
+pkgrel=2
pkgdesc="Library to communicate using the JSON-RPC 2.0 specification"
url="https://gitlab.gnome.org/GNOME/jsonrpc-glib"
arch="all"
license="GPL-3.0-or-later"
makedepends="gtk+3.0-dev vala gobject-introspection-dev meson json-glib-dev"
subpackages="$pkgname-dev"
-source="https://download.gnome.org/sources/jsonrpc-glib/${pkgver%.*}/jsonrpc-glib-$pkgver.tar.xz
- disable-flaky-test.patch"
+source="https://download.gnome.org/sources/jsonrpc-glib/${pkgver%.*}/jsonrpc-glib-$pkgver.tar.xz"
build() {
abuild-meson \
+ -Db_lto=true \
-Denable_gtk_doc=false \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="1862403c37b7140e91720264a1b00a408b969f0464fc022a5c24be0eea993526d118ece6611927e1309071c3db9d3d6bf9f13ae8ed23ff1d34f36fb68c2584cd jsonrpc-glib-3.38.0.tar.xz
-ec2eea185a86c6ac16fc51c7d67faca7805c69e6127f1288d551ba7249f898672a5a4ef1f2d05531f65e5d5087d4d576b251f3330806809bdeab6abd6593dc34 disable-flaky-test.patch"
+sha512sums="
+85962af18cb62af7c4dfa37289cf53ba9c905ee00994cc6bcc2679f1e0f79ea0b134386179dd2417e6166777d65f025959d6d258aa279bbfb1f4cacceeede7af jsonrpc-glib-3.44.0.tar.xz
+"