aboutsummaryrefslogtreecommitdiffstats
path: root/community/jupyter-nbclient/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/jupyter-nbclient/APKBUILD')
-rw-r--r--community/jupyter-nbclient/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/community/jupyter-nbclient/APKBUILD b/community/jupyter-nbclient/APKBUILD
index 2cac96b725c..78c27ae52ad 100644
--- a/community/jupyter-nbclient/APKBUILD
+++ b/community/jupyter-nbclient/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Aiden Grossman <agrossman154@yahoo.com>
# Maintainer: Aiden Grossman <agrossman154@yahoo.com>
pkgname=jupyter-nbclient
-pkgver=0.6.6
-pkgrel=0
+pkgver=0.8.0
+pkgrel=1
pkgdesc="Client library for executing notebooks"
url="https://github.com/jupyter/nbclient"
arch="noarch"
@@ -13,14 +13,17 @@ depends="
py3-nest_asyncio
py3-traitlets
"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest py3-xmltodict jupyter-nbconvert py3-ipykernel"
+makedepends="py3-gpep517 py3-hatchling"
+checkdepends="py3-pytest py3-xmltodict jupyter-nbconvert py3-ipykernel py3-flaky"
options="!check" # circular dependency with jupyter-nbconvert
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/jupyter/nbclient/archive/refs/tags/v$pkgver.tar.gz"
builddir="$srcdir/nbclient-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -30,9 +33,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer --destdir="$pkgdir" .dist/*.whl
}
sha512sums="
-8ca0333a47920994d8afe7c8943b366d4669e7ad91daab1a36c57480b70e51dfd05c7cd44acd2a2005b8c0a6b41c4fe6be0fc22b75a3efe291e9c35dd334643c jupyter-nbclient-0.6.6.tar.gz
+f77ecba2f03a8886e8a2335e1d345fcc1d3a1726b458d151a8c78b85c621017cd96f1ef30e4532bf61b89c92aea128a364f5e9677858951f5d070c6206a01816 jupyter-nbclient-0.8.0.tar.gz
"