aboutsummaryrefslogtreecommitdiffstats
path: root/community/jupyter-nbclient/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/jupyter-nbclient/APKBUILD')
-rw-r--r--community/jupyter-nbclient/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/jupyter-nbclient/APKBUILD b/community/jupyter-nbclient/APKBUILD
new file mode 100644
index 00000000000..4de54c93df4
--- /dev/null
+++ b/community/jupyter-nbclient/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Aiden Grossman <agrossman154@yahoo.com>
+# Maintainer: Aiden Grossman <agrossman154@yahoo.com>
+pkgname=jupyter-nbclient
+pkgver=0.10.0
+pkgrel=0
+pkgdesc="Client library for executing notebooks"
+url="https://github.com/jupyter/nbclient"
+arch="noarch"
+license="BSD-3-Clause"
+depends="
+ py3-jupyter_client
+ jupyter-nbformat
+ py3-nest_asyncio
+ py3-traitlets
+ "
+makedepends="py3-gpep517 py3-hatchling"
+checkdepends="py3-pytest py3-xmltodict jupyter-nbconvert py3-ipykernel py3-flaky"
+options="!check" # circular dependency with jupyter-nbconvert
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jupyter/nbclient/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir/nbclient-$pkgver"
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ pytest \
+ --deselect nbclient/tests/test_client.py::TestExecute::test_widgets \
+ --deselect nbclient/tests/test_client.py::test_run_all_notebooks
+}
+
+package() {
+ python3 -m installer --destdir="$pkgdir" .dist/*.whl
+}
+
+sha512sums="
+5dce724477c81fd02299a36786aa18e7fc19ccd64a40ae5cb48fce889300ce6eea303194cd35a66201579d3ce6aa201b57378bd9855ed3da4e720246711f3226 jupyter-nbclient-0.10.0.tar.gz
+"