aboutsummaryrefslogtreecommitdiffstats
path: root/community/jupyter-nbformat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/jupyter-nbformat/APKBUILD')
-rw-r--r--community/jupyter-nbformat/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/jupyter-nbformat/APKBUILD b/community/jupyter-nbformat/APKBUILD
new file mode 100644
index 00000000000..ea669518ff4
--- /dev/null
+++ b/community/jupyter-nbformat/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Aiden Grossman <agrossman154@yahoo.com>
+# Maintainer: Aiden Grossman <agrossman154@yahoo.com>
+pkgname=jupyter-nbformat
+pkgver=5.9.2
+pkgrel=1
+pkgdesc="Reference implemtnation of the jupyter notebook format"
+url="https://github.com/jupyter/nbformat"
+arch="noarch"
+license="BSD-3-Clause"
+makedepends="py3-gpep517 py3-installer py3-hatch-nodejs-version"
+depends="py3-traitlets py3-jsonschema py3-fastjsonschema py3-jupyter_core"
+checkdepends="py3-pytest py3-testpath py3-pep440"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jupyter/nbformat/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir/nbformat-$pkgver"
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -p no:warnings
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+}
+
+sha512sums="
+a345413fbb2e9920c484be9591622df62a9c28f5cec0494a03a941363f58437b075028d5fe4bbac8a6933f1737596780b8bb004fa0736240a497a2093bef8011 jupyter-nbformat-5.9.2.tar.gz
+"