aboutsummaryrefslogtreecommitdiffstats
path: root/community/jupyter-nbformat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/jupyter-nbformat/APKBUILD')
-rw-r--r--community/jupyter-nbformat/APKBUILD28
1 files changed, 18 insertions, 10 deletions
diff --git a/community/jupyter-nbformat/APKBUILD b/community/jupyter-nbformat/APKBUILD
index 256a9d560be..efb3fecdee7 100644
--- a/community/jupyter-nbformat/APKBUILD
+++ b/community/jupyter-nbformat/APKBUILD
@@ -1,30 +1,38 @@
# Contributor: Aiden Grossman <agrossman154@yahoo.com>
# Maintainer: Aiden Grossman <agrossman154@yahoo.com>
pkgname=jupyter-nbformat
-pkgver=5.4.0
-pkgrel=1
+pkgver=5.10.4
+pkgrel=0
pkgdesc="Reference implemtnation of the jupyter notebook format"
url="https://github.com/jupyter/nbformat"
arch="noarch"
license="BSD-3-Clause"
-makedepends="py3-setuptools"
-depends="py3-traitlets py3-jsonschema py3-fastjsonschema py3-jupyter_core py3-ipython_genutils"
-checkdepends="py3-pytest py3-testpath"
-source="$pkgname-$pkgver.tar.gz::https://github.com/jupyter/nbformat/archive/refs/tags/$pkgver.tar.gz"
+makedepends="py3-gpep517 py3-installer py3-hatch-nodejs-version"
+depends="py3-traitlets py3-jsonschema py3-fastjsonschema py3-jupyter_core"
+checkdepends="py3-pytest py3-testpath py3-pep440"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jupyter/nbformat/archive/refs/tags/v$pkgver.tar.gz"
builddir="$srcdir/nbformat-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ # https://github.com/jupyter/nbformat/issues/232
+ .testenv/bin/python3 -m pytest -p no:warnings \
+ --ignore tests/test_validator.py
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-f601438193bfcb11f1ceed74995ab6862ff8c916f9bddabe38fd70bb997f4407bede4318ae7034d75424b20b75846010ddda2a45b8fe8de6dd9310617b00fb9d jupyter-nbformat-5.4.0.tar.gz
+efea58449a0aaf6d6531e5c94460ca67dcb0289bbfc0db0f0bb1898d13c1f161a289f856a858f8d9c0d3ae40e054fa3676eba73fac10d802d3e40fb2d10016eb jupyter-nbformat-5.10.4.tar.gz
"