aboutsummaryrefslogtreecommitdiffstats
path: root/community/jupyter-nbformat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/jupyter-nbformat/APKBUILD')
-rw-r--r--community/jupyter-nbformat/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/jupyter-nbformat/APKBUILD b/community/jupyter-nbformat/APKBUILD
new file mode 100644
index 00000000000..efb3fecdee7
--- /dev/null
+++ b/community/jupyter-nbformat/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Aiden Grossman <agrossman154@yahoo.com>
+# Maintainer: Aiden Grossman <agrossman154@yahoo.com>
+pkgname=jupyter-nbformat
+pkgver=5.10.4
+pkgrel=0
+pkgdesc="Reference implemtnation of the jupyter notebook format"
+url="https://github.com/jupyter/nbformat"
+arch="noarch"
+license="BSD-3-Clause"
+makedepends="py3-gpep517 py3-installer py3-hatch-nodejs-version"
+depends="py3-traitlets py3-jsonschema py3-fastjsonschema py3-jupyter_core"
+checkdepends="py3-pytest py3-testpath py3-pep440"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jupyter/nbformat/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir/nbformat-$pkgver"
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ # https://github.com/jupyter/nbformat/issues/232
+ .testenv/bin/python3 -m pytest -p no:warnings \
+ --ignore tests/test_validator.py
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+}
+
+sha512sums="
+efea58449a0aaf6d6531e5c94460ca67dcb0289bbfc0db0f0bb1898d13c1f161a289f856a858f8d9c0d3ae40e054fa3676eba73fac10d802d3e40fb2d10016eb jupyter-nbformat-5.10.4.tar.gz
+"