aboutsummaryrefslogtreecommitdiffstats
path: root/community/jupyter-notebook/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/jupyter-notebook/APKBUILD')
-rw-r--r--community/jupyter-notebook/APKBUILD42
1 files changed, 20 insertions, 22 deletions
diff --git a/community/jupyter-notebook/APKBUILD b/community/jupyter-notebook/APKBUILD
index 7b659f1ad5c..72ebc31fae4 100644
--- a/community/jupyter-notebook/APKBUILD
+++ b/community/jupyter-notebook/APKBUILD
@@ -1,46 +1,47 @@
# Contributor: Aiden Grossman <agrossman154@yahoo.com>
# Maintainer: Aiden Grossman <agrossman154@yahoo.com>
pkgname=jupyter-notebook
-pkgver=6.4.10
-pkgrel=0
+pkgver=6.5.6
+pkgrel=1
pkgdesc="Jupyter interactive notebook"
url="https://github.com/jupyter/notebook"
# py3-argon2-cffi is not available on s390x
# bower/npm not present on riscv64
-arch="noarch !s390x !riscv64"
+# jupyter-nbclassic not present on ppc64le/armhf
+arch="noarch !armhf !s390x !riscv64 !ppc64le"
license="BSD-3-Clause"
-depends="py3-jupyter_core
- py3-ipython_genutils
- py3-tornado
- jupyter-nbformat
- mathjax2
+depends="
+ jupyter-nbclassic
jupyter-nbconvert
+ jupyter-nbformat
+ py3-argon2-cffi
py3-ipykernel
- py3-nest_asyncio
- py3-send2trash
+ py3-ipython_genutils
+ py3-jinja2
py3-jupyter_client
+ py3-jupyter_core
+ py3-nest_asyncio
py3-prometheus-client
- py3-jinja2
- py3-terminado
py3-pyzmq
- py3-argon2-cffi
+ py3-send2trash
+ py3-terminado
+ py3-tornado
py3-traitlets
"
makedepends="bower npm py3-setuptools"
checkdepends="py3-pytest"
options="!check" # lots of unpackaged dependencies + many dependencies would only work on x86_64
-source="$pkgname-$pkgver.tar.gz::https://github.com/jupyter/notebook/archive/refs/tags/$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jupyter/notebook/archive/refs/tags/v$pkgver.tar.gz"
builddir="$srcdir/notebook-$pkgver"
# secfixes:
+# 6.4.12-r0:
+# - CVE-2022-29238
# 6.4.10-r0:
# - CVE-2022-24758
build() {
- # use system mathjax
- sed -i 's/^.*MathJax.*$//' bower.json
- sed -i 's/ mj(/ #mj(/' setupbase.py
-
python3 setup.py build
}
@@ -50,11 +51,8 @@ check() {
package() {
python3 setup.py install --prefix="/usr" --root="$pkgdir"
-
- # set install to use system mathjax
- ln -s /usr/share/mathjax2 "$pkgdir/usr/lib/python3.10/site-packages/notebook/static/components/MathJax"
}
sha512sums="
-5640844f1dbe7c2d536ed2f257f2d0f003683e7e7660fef8ed03a0db8bb80893efb6ae482de6be7e8f7cb68789174f43da028d0d39068bb1a3d6b8e59c5182f6 jupyter-notebook-6.4.10.tar.gz
+388df9e5e3f329c27353cd368693ae93e4d2efc00f81a96919367518ef742d1e69e34852ef732dc9ef940dab3bbe16406a133a7cc0045f1e2eeb2961af701faf jupyter-notebook-6.5.6.tar.gz
"