aboutsummaryrefslogtreecommitdiffstats
path: root/community/jupyter-notebook/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/jupyter-notebook/APKBUILD')
-rw-r--r--community/jupyter-notebook/APKBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/community/jupyter-notebook/APKBUILD b/community/jupyter-notebook/APKBUILD
new file mode 100644
index 00000000000..d7cc2542fbc
--- /dev/null
+++ b/community/jupyter-notebook/APKBUILD
@@ -0,0 +1,58 @@
+# Contributor: Aiden Grossman <agrossman154@yahoo.com>
+# Maintainer: Aiden Grossman <agrossman154@yahoo.com>
+pkgname=jupyter-notebook
+pkgver=6.5.6
+pkgrel=0
+pkgdesc="Jupyter interactive notebook"
+url="https://github.com/jupyter/notebook"
+# py3-argon2-cffi is not available on s390x
+# bower/npm not present on riscv64
+# jupyter-nbclassic not present on ppc64le/armhf
+arch="noarch !armhf !s390x !riscv64 !ppc64le"
+license="BSD-3-Clause"
+depends="
+ jupyter-nbclassic
+ jupyter-nbconvert
+ jupyter-nbformat
+ py3-argon2-cffi
+ py3-ipykernel
+ py3-ipython_genutils
+ py3-jinja2
+ py3-jupyter_client
+ py3-jupyter_core
+ py3-nest_asyncio
+ py3-prometheus-client
+ py3-pyzmq
+ py3-send2trash
+ py3-terminado
+ py3-tornado
+ py3-traitlets
+ "
+makedepends="bower npm py3-setuptools"
+checkdepends="py3-pytest"
+options="!check" # lots of unpackaged dependencies + many dependencies would only work on x86_64
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jupyter/notebook/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir/notebook-$pkgver"
+
+# secfixes:
+# 6.4.12-r0:
+# - CVE-2022-29238
+# 6.4.10-r0:
+# - CVE-2022-24758
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix="/usr" --root="$pkgdir"
+}
+
+sha512sums="
+388df9e5e3f329c27353cd368693ae93e4d2efc00f81a96919367518ef742d1e69e34852ef732dc9ef940dab3bbe16406a133a7cc0045f1e2eeb2961af701faf jupyter-notebook-6.5.6.tar.gz
+"