aboutsummaryrefslogtreecommitdiffstats
path: root/community/just/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/just/APKBUILD')
-rw-r--r--community/just/APKBUILD44
1 files changed, 26 insertions, 18 deletions
diff --git a/community/just/APKBUILD b/community/just/APKBUILD
index 99e65b864fc..946d8498ae9 100644
--- a/community/just/APKBUILD
+++ b/community/just/APKBUILD
@@ -1,49 +1,57 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=just
-pkgver=0.10.2
+pkgver=1.25.2
pkgrel=0
pkgdesc="Just a command runner"
url="https://github.com/casey/just"
-arch="x86_64 armv7 armhf aarch64 x86 ppc64le" # limited by rust/cargo
+# riscv64: rust currently broken on this arch
+# s390x: blocked by nix crate
+arch="all !riscv64 !s390x"
license="CC0-1.0"
checkdepends="bash fzf"
-makedepends="cargo"
+makedepends="cargo cargo-auditable"
subpackages="
+ $pkgname-doc
$pkgname-bash-completion
$pkgname-fish-completion
$pkgname-zsh-completion
"
-source="https://github.com/casey/just/archive/$pkgver/just-$pkgver.tar.gz
- minimize-size.patch
- "
+source="https://github.com/casey/just/archive/$pkgver/just-$pkgver.tar.gz"
+
+export CARGO_PROFILE_RELEASE_OPT_LEVEL="z"
+
+prepare() {
+ default_prepare
+
+ cargo fetch --target="$CTARGET" --locked
+}
build() {
- cargo build --release --locked
+ cargo auditable build --release --frozen
}
check() {
# Skipped tests are somehow broken.
- cargo test --locked -- \
+ cargo test --frozen -- \
--skip choose::default \
--skip edit::editor_precedence \
- --skip choose::multiple_recipes \
- --skip misc::env_var_functions
+ --skip functions::env_var_functions
}
package() {
- cargo install --locked --path . --root="$pkgdir/usr"
- rm "$pkgdir"/usr/.crates*
+ install -D -m755 target/release/just -t "$pkgdir"/usr/bin/
+
+ install -D -m644 man/just.1 -t "$pkgdir"/usr/share/man/man1/
- install -D -m 644 completions/just.bash \
+ install -D -m644 completions/just.bash \
"$pkgdir"/usr/share/bash-completion/completions/$pkgname
- install -D -m 644 completions/just.fish \
- "$pkgdir"/usr/share/fish/completions/$pkgname.fish
- install -D -m 644 completions/just.zsh \
+ install -D -m644 completions/just.fish \
+ "$pkgdir"/usr/share/fish/vendor_completions.d/$pkgname.fish
+ install -D -m644 completions/just.zsh \
"$pkgdir"/usr/share/zsh/site-functions/_$pkgname
}
sha512sums="
-881f7dae7b7fbfe93e55e7c603cfa71756c67739788d49250e8792b87dcb6321b5fa7a2f8dbf9edc99a78daefd899ebfa2e20f0ea8ca07ff0f18b606944af35d just-0.10.2.tar.gz
-413f4c196e88d1d33cd6bc01a5ed920f6f5cde3c71c5c9117541fd40536ed0f90e4b7baf20670e548dfcd9705c608b591294915d7632343d0b3f9fdb33d3e098 minimize-size.patch
+651e132d98160ace78f1e6aa55fe7e697709322eac3aad37630d41eda8381652c876a69ec82663f174390c1bc1dfcfd734b052660e625919e6c78922ae74ce4e just-1.25.2.tar.gz
"