aboutsummaryrefslogtreecommitdiffstats
path: root/community/kaccounts-integration/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kaccounts-integration/APKBUILD')
-rw-r--r--community/kaccounts-integration/APKBUILD20
1 files changed, 6 insertions, 14 deletions
diff --git a/community/kaccounts-integration/APKBUILD b/community/kaccounts-integration/APKBUILD
index 4c10e559a39..a0f7cbbe98d 100644
--- a/community/kaccounts-integration/APKBUILD
+++ b/community/kaccounts-integration/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kaccounts-integration
-pkgver=19.12.2
-pkgrel=1
+pkgver=19.12.3
+pkgrel=0
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://kde.org/applications/internet/"
pkgdesc="Small system to administer web accounts for the sites and services across the KDE desktop"
@@ -14,24 +14,16 @@ source="https://download.kde.org/stable/release-service/$pkgver/src/kaccounts-in
subpackages="$pkgname-dev $pkgname-lang"
options="!check" # No tests available
-prepare() {
- default_prepare
-
- mkdir "$builddir"/build
-}
-
build() {
- cd "$builddir"/build
- cmake "$builddir" \
+ cmake -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
- make
+ make -C build
}
package() {
- cd "$builddir"/build
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" make -C build install
}
-sha512sums="378f8d8d5cc470fbd70e197dd472331b648bdf498d9df4a45779aa3d7675c6f196c87ba43ed035f178bbdc9474b74dc1ed1ed7b0a48f83ce651971696d2bdf3e kaccounts-integration-19.12.2.tar.xz"
+sha512sums="3bf8850d9d81001c30bf6fb62178501bd45e6e447093fa63f32cba0b17cb83eadc518f439653c6212e80f20be7cb76a912a632a286e94b15fa8d9c2c6ad9e681 kaccounts-integration-19.12.3.tar.xz"