aboutsummaryrefslogtreecommitdiffstats
path: root/community/kaccounts-integration/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kaccounts-integration/APKBUILD')
-rw-r--r--community/kaccounts-integration/APKBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/community/kaccounts-integration/APKBUILD b/community/kaccounts-integration/APKBUILD
index e59acc923ce..e1ea5d25d39 100644
--- a/community/kaccounts-integration/APKBUILD
+++ b/community/kaccounts-integration/APKBUILD
@@ -1,11 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kaccounts-integration
-pkgver=21.12.1
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64, ppc64le and riscv64 blocked by signon-ui and kdeclarative
-arch="all !armhf !s390x !mips64 !ppc64le !riscv64"
+# s390x, ppc64le, riscv64 blocked by signon-ui -> qt6-qtwebengine
+arch="all !armhf !s390x !ppc64le !riscv64"
url="https://kde.org/applications/internet/"
pkgdesc="Small system to administer web accounts for the sites and services across the KDE desktop"
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
@@ -20,19 +23,22 @@ depends_dev="
kdeclarative-dev
ki18n-dev
libaccounts-qt-dev
- qt5-qtbase-dev
+ qcoro-dev
+ qt6-qtbase-dev
signond-dev
"
makedepends="$depends_dev
extra-cmake-modules
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kaccounts-integration-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-lang"
+_repo_url="https://invent.kde.org/network/kaccounts-integration.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kaccounts-integration-$pkgver.tar.xz"
options="!check" # No tests available
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -43,5 +49,5 @@ package() {
}
sha512sums="
-9393d8833d28f5169c45c0246b05b00ad97db1579751941f8a138a131233d2f0df70c55154298fa0653773c19be1766e828f0c5d2d961c4161dea49b130213c6 kaccounts-integration-21.12.1.tar.xz
+214d0bb5a16d539adb6d1007a57b67e09ff2b96208891649945f427efca593d2c2ba1534ca048c6fa1ac97606e9f85c6d2448760a6101114665afa706c94b469 kaccounts-integration-24.02.2.tar.xz
"