aboutsummaryrefslogtreecommitdiffstats
path: root/community/kaidan/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kaidan/APKBUILD')
-rw-r--r--community/kaidan/APKBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/community/kaidan/APKBUILD b/community/kaidan/APKBUILD
index 452a3a1a5e3..bf97208e965 100644
--- a/community/kaidan/APKBUILD
+++ b/community/kaidan/APKBUILD
@@ -1,21 +1,26 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kaidan
-pkgver=0.8.0
-pkgrel=1
+pkgver=0.9.1
+pkgrel=4
pkgdesc="Kaidan, a simple and user-friendly Jabber/XMPP client for every device and platform"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
-url="https://invent.kde.org/kde/kaidan"
+url="https://invent.kde.org/network/kaidan"
license="GPL-3.0-or-later-with-openssl-exception AND GPL-3.0-or-later AND MIT AND AND Apache-2.0 AND CC-BY-SA-4.0 AND CC-BY-SA-3.0"
depends="
+ kirigami-addons
kirigami2
+ kquickimageeditor
qt5-qtbase-sqlite
qt5-qtquickcontrols
"
makedepends="
extra-cmake-modules
+ kio5-dev
+ kirigami-addons-dev
kirigami2-dev
- knotifications-dev
+ knotifications5-dev
+ kquickimageeditor-dev
qt5-qtbase-dev
qt5-qtdeclarative-dev
qt5-qtlocation-dev
@@ -24,14 +29,16 @@ makedepends="
qt5-qtsvg-dev
qt5-qttools-dev
qxmpp-dev
+ samurai
zxing-cpp-dev
"
-source="https://download.kde.org/unstable/kaidan/$pkgver/kaidan-$pkgver.tar.xz"
+subpackages="$pkgname-lang"
+source="https://download.kde.org/unstable/kaidan/kaidan-$pkgver.tar.xz"
options="!check" # No tests
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DQUICK_COMPILER=TRUE \
@@ -44,5 +51,5 @@ package() {
}
sha512sums="
-2084693dd2ae0f1410e6df57f77f1c2c080e9b48c771e632b4cc9bf0351e435fd9d6937209f50d0f41a7235317fe42578cc8c983163f61e0d6c541d148a202bf kaidan-0.8.0.tar.xz
+256daeb94f4275377e1ef0919eb43660dd76064c414f1ac5570fac33632f853977997c52a504d5dace188f560feac93ea88ae1bb796e2bf6a96bafa4be387cbb kaidan-0.9.1.tar.xz
"