aboutsummaryrefslogtreecommitdiffstats
path: root/community/kalarm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kalarm/APKBUILD')
-rw-r--r--community/kalarm/APKBUILD75
1 files changed, 63 insertions, 12 deletions
diff --git a/community/kalarm/APKBUILD b/community/kalarm/APKBUILD
index 329675dec48..8961d3d64d7 100644
--- a/community/kalarm/APKBUILD
+++ b/community/kalarm/APKBUILD
@@ -1,32 +1,83 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kalarm
-pkgver=20.08.3
+pkgver=24.02.2
pkgrel=0
-arch="all !ppc64le !s390x !armhf !mips !mips64" # Limited by kmailtransport -> libkgapi -> qt5-qtwebengine
-url="https://kontact.kde.org/"
pkgdesc="Personal alarm scheduler"
+url="https://kontact.kde.org/"
+# armhf blocked by extra-cmake-modules
+# ppc64le, s390x, riscv64 and armv7 blocked by qt6-qtwebengine -> akonadi
+arch="all !armhf !ppc64le !s390x !riscv64 !armv7"
license="GPL-2.0-or-later AND GFDL-1.2-only"
depends="kdepim-runtime"
-makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtx11extras-dev kauth-dev kcodecs-dev kcompletion-dev kconfig-dev kconfigwidgets-dev kdbusaddons-dev kdoctools-dev kglobalaccel-dev kguiaddons-dev ki18n-dev kiconthemes-dev kjobwidgets-dev kcmutils-dev kdelibs4support-dev kio-dev knotifications-dev kservice-dev kwidgetsaddons-dev kwindowsystem-dev kxmlgui-dev kholidays-dev phonon-dev kimap-dev akonadi-dev akonadi-contacts-dev akonadi-mime-dev kalarmcal-dev kcalendarcore-dev kcalutils-dev kidentitymanagement-dev kdepim-apps-libs-dev libkdepim-dev mailcommon-dev kmailtransport-dev kmime-dev pimcommon-dev kpimtextedit-dev libxslt-dev qgpgme"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kalarm-$pkgver.tar.xz"
+makedepends="
+ akonadi-contacts-dev
+ akonadi-dev
+ akonadi-mime-dev
+ extra-cmake-modules
+ kauth-dev
+ kcalendarcore-dev
+ kcalutils-dev
+ kcmutils-dev
+ kcodecs-dev
+ kcompletion-dev
+ kconfig-dev
+ kconfigwidgets-dev
+ kdbusaddons-dev
+ kdoctools-dev
+ kglobalaccel-dev
+ kguiaddons-dev
+ kholidays-dev
+ ki18n-dev
+ kiconthemes-dev
+ kidentitymanagement-dev
+ kidletime-dev
+ kimap-dev
+ kio-dev
+ kjobwidgets-dev
+ kmailtransport-dev
+ kmime-dev
+ knotifications-dev
+ knotifyconfig-dev
+ kpimtextedit-dev
+ kservice-dev
+ kstatusnotifieritem-dev
+ ktextwidgets-dev
+ kwidgetsaddons-dev
+ kwindowsystem-dev
+ kxmlgui-dev
+ libkdepim-dev
+ libxslt-dev
+ mailcommon-dev
+ phonon-dev
+ pimcommon-dev
+ qgpgme
+ qt6-qtbase-dev
+ samurai
+ "
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/kalarm.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kalarm-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja\
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure -E "(kadatetime|kaevent)test"
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="d564922bf41f176034535fd795d25eeabfbcd8e7eea115c29e5c0f1a2313de5b33406f87e1f7e705d7f814b9a2b826ac4cf7ac50723bf90beea5ecc92c750496 kalarm-20.08.3.tar.xz"
+sha512sums="
+2de2d881e3a2a959b1d4f2e25415fdbdba1adf68578ab2f489cde9a51ef63f7909e686bf869992809ae615dc3caad3cd337fa7bf6d66a1f323996785c4be1f57 kalarm-24.02.2.tar.xz
+"