aboutsummaryrefslogtreecommitdiffstats
path: root/community/kalzium/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kalzium/APKBUILD')
-rw-r--r--community/kalzium/APKBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/community/kalzium/APKBUILD b/community/kalzium/APKBUILD
new file mode 100644
index 00000000000..87bd3962fdb
--- /dev/null
+++ b/community/kalzium/APKBUILD
@@ -0,0 +1,56 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
+pkgname=kalzium
+pkgver=24.02.2
+pkgrel=0
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
+url="https://edu.kde.org/kalzium/"
+pkgdesc="Periodic Table of Elements"
+license="GPL-2.0-or-later AND LGPL-2.0-or-later AND GFDL-1.2-only"
+makedepends="
+ eigen-dev
+ extra-cmake-modules
+ karchive-dev
+ kconfig-dev
+ kcoreaddons-dev
+ kdoctools-dev
+ ki18n-dev
+ knewstuff-dev
+ kparts-dev
+ kplotting-dev
+ kunitconversion-dev
+ kwidgetsaddons-dev
+ qt6-qtbase-dev
+ qt6-qtscxml-dev
+ qt6-qtsvg-dev
+ samurai
+ solid-dev
+ "
+_repo_url="https://invent.kde.org/education/kalzium.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kalzium-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang $pkgname-dev"
+
+build() {
+ cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ cmake --build build
+}
+
+check() {
+ ctest --test-dir build --output-on-failure
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+
+sha512sums="
+7cf5c46a175014c61766a2c0edcac2ca66405053c85a842b40ceca8afbfc5f9130f684b146f54626558d14c70e95f1684d116004816ee5899bd5b4f668947b21 kalzium-24.02.2.tar.xz
+"