aboutsummaryrefslogtreecommitdiffstats
path: root/community/kanshi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kanshi/APKBUILD')
-rw-r--r--community/kanshi/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/kanshi/APKBUILD b/community/kanshi/APKBUILD
new file mode 100644
index 00000000000..cf5a2aa3145
--- /dev/null
+++ b/community/kanshi/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Contributor: Michał Polański <michal@polanski.me>
+# Maintainer: Michał Polański <michal@polanski.me>
+pkgname=kanshi
+pkgver=1.5.1
+pkgrel=0
+pkgdesc="Dynamic display configuration for Wayland"
+url="https://wayland.emersion.fr/kanshi/"
+license="MIT"
+arch="all"
+options="!check" # no test suite
+makedepends="meson varlink-dev wayland-dev scdoc"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~emersion/kanshi/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-v$pkgver"
+
+build() {
+ abuild-meson . output
+ meson compile -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+
+sha512sums="
+0fe5fa584febe29b80eb8e896cc87734de83a7a5021e027bb864a9da9b8b333db3584f83885c2870907f4a1ec5ef8bb386356a037b7560643c4badec811bb1aa kanshi-1.5.1.tar.gz
+"