aboutsummaryrefslogtreecommitdiffstats
path: root/community/kapman/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kapman/APKBUILD')
-rw-r--r--community/kapman/APKBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/community/kapman/APKBUILD b/community/kapman/APKBUILD
index a30db76ff9f..07357c91869 100644
--- a/community/kapman/APKBUILD
+++ b/community/kapman/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kapman
-pkgver=21.08.2
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/games/org.kde.kapman"
pkgdesc="A clone of the well known game Pac-Man"
license="GPL-2.0-or-later AND GFDL-1.2-only"
@@ -21,24 +23,24 @@ makedepends="
ki18n-dev
kxmlgui-dev
libkdegames-dev
- qt5-qtbase-dev
- qt5-qtsvg-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kapman-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/games/kapman.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kapman-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -46,5 +48,5 @@ package() {
}
sha512sums="
-70b7aee6e98ab1c0d48787a588deb1afd90cc7a8a6a628ca7347594661286889c019bae37dc9afc9fbb370cc5766341fe4b84b149789ba95a437a71ca7ec6a10 kapman-21.08.2.tar.xz
+a78f345a126cf9553fe1793189e04520e6eef749fb29549d7e9c9c40057c8e2e532151b9df11de152f1528ad6558463698f8e004c396626c52bd1806f5c391df kapman-24.02.2.tar.xz
"