aboutsummaryrefslogtreecommitdiffstats
path: root/community/kapman/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kapman/APKBUILD')
-rw-r--r--community/kapman/APKBUILD32
1 files changed, 18 insertions, 14 deletions
diff --git a/community/kapman/APKBUILD b/community/kapman/APKBUILD
index c01b0c4daef..8664c204f77 100644
--- a/community/kapman/APKBUILD
+++ b/community/kapman/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kapman
-pkgver=21.04.0
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x blocked by kconfigwidgets
-arch="all !armhf !s390x !mips64"
+arch="all !armhf"
url="https://kde.org/applications/games/org.kde.kapman"
pkgdesc="A clone of the well known game Pac-Man"
license="GPL-2.0-or-later AND GFDL-1.2-only"
@@ -21,28 +23,30 @@ makedepends="
ki18n-dev
kxmlgui-dev
libkdegames-dev
- qt5-qtbase-dev
- qt5-qtsvg-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kapman-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/games/kapman.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kapman-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="e0d47fb40bbb04e90eea421c40d2ad8d0c1d04485276e00767e2ed3f083951f38ea18d13611f666bd001a8eb434ce51c1f10eb51f954af6e59e69b1c39d92a09 kapman-21.04.0.tar.xz"
+sha512sums="
+903b0c0636a86dcaf7c656efb7c393416ac81df505f282415354f594586cf750d2a9ba4aa3ea56fccbca45a2a7005df6b834bcc162f4b00b7e0f108bd7e485bd kapman-24.02.1.tar.xz
+"