aboutsummaryrefslogtreecommitdiffstats
path: root/community/kapptemplate/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kapptemplate/APKBUILD')
-rw-r--r--community/kapptemplate/APKBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/community/kapptemplate/APKBUILD b/community/kapptemplate/APKBUILD
index a1203edd922..86f24e54d5f 100644
--- a/community/kapptemplate/APKBUILD
+++ b/community/kapptemplate/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kapptemplate
-pkgver=21.04.3
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/development/org.kde.kapptemplate"
pkgdesc="Factory for the easy creation of KDE/Qt components and programs"
license="GPL-2.0-or-later AND GFDL-1.2-only"
@@ -18,22 +20,23 @@ makedepends="
kdoctools-dev
ki18n-dev
kio-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kapptemplate-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/sdk/kapptemplate.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kapptemplate-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -41,5 +44,5 @@ package() {
}
sha512sums="
-15a5a8b143ac58300f9f01ca0c37889ab6498b214fdd77c8aa50743015e6ce40f93578b0eb1cbef39fed8505851db2a170eb8f3850a126a2c38a8e4f49984ad2 kapptemplate-21.04.3.tar.xz
+b206414862528d4f5d0a30488efe35c90a4558b455f619b315861df95556442bab45c5a77d08a7f0a149a5b7e99d449aa4c480b6f2f1be86da6a228214e1abae kapptemplate-24.02.2.tar.xz
"